1142 Maximal Clique(25 分)(C++)

clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

题目大意:给一个图,再给出一些点,判断这些点是否两两相通,同时判断是否还在其他的点与这些点两两相通。

解题思路:是否两两相通这个设一个数组,记录所有的路径即可,是否还存在其他的点,用set容器记录第一个点所有的邻边点,判断这些邻边点与剩下的点是否两两相通即可。重点留意一下自身点的路径记录以及相通判断。

Tips:

这题纠正了我erase上认识的不足;

for(auto it=s.begin();it!=s.end();it++){
         if(e[*it][temp[v]]==false)
                s.erase(it);
           }

以上代码是错的,对任意一个容器都不正确。

原因:可以参考这篇文章https://www.techiedelight.com/remove-elements-set-cpp/

简单来说,就是当执行了erase之后,返回一个迭代器其实是指向被删除元素的迭代器的后一个,如果按照上述处理方式,it指向的被删除的元素,其实是不明确的,上文给了几种解决方式,我也简单地写一下:

//方法一:复制一个指向需要删除的元素的后一个迭代器
for(auto it = s.begin(); it != s.end()){
    if(*it < target){
        auto dup = it ++;
        s.erase(it);
        it = dup;
    }
    else
        it ++;
}
//方法二:提前将it指向下一个
for(auto it = s.begin(); it != s.end()){
    if(*it < target)
        s.erase(it ++);
    else
        it ++;
}

//方法三:利用erase返回被删除的元素的后一个迭代器
for(auto it = s.begin(); it != s.end()){
    if(*it < target)
        it = s.erase(it);
    else
        it ++;
}
#include <iostream>
#include <set>
#include <vector>
using namespace std;
bool e[205][205];
int n, m, k, cnt;
int main(){
	scanf("%d %d", &n, &m);
	for(int i = 0; i < m; ++ i){
		int a, b;
		scanf("%d %d", &a, &b);
		e[a][b] = e[b][a] = true;
	}
	scanf("%d", &k);
	for(int i = 0; i < k; ++ i){
		scanf("%d", &cnt);
		set<int>ans;
		vector<int>val(cnt);
		bool flag = true;
		for(int j = 0; j < cnt; ++ j)
			scanf("%d", &val[j]);
		ans.insert(val[0]);
		for(int j = 1; j <= n; ++ j)
			if(e[val[0]][j] == true)
				ans.insert(j);
		for(int j = 1; j < cnt; ++ j){
			if(ans.find(val[j]) == ans.end()){
				flag = false;
				break;
			}
			for(auto it = ans.begin(); it != ans.end();)
				if(*it != val[j] && e[*it][val[j]] == false)
					ans.erase(it ++);
				else
					it ++;
		}
		printf("%s\n",flag == false ? "Not a Clique" : ans.size() != cnt ? "Not Maximal" : "Yes");
	}
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
完整版:https://download.csdn.net/download/qq_27595745/89522468 【课程大纲】 1-1 什么是java 1-2 认识java语言 1-3 java平台的体系结构 1-4 java SE环境安装和配置 2-1 java程序简介 2-2 计算机中的程序 2-3 java程序 2-4 java类库组织结构和文档 2-5 java虚拟机简介 2-6 java的垃圾回收器 2-7 java上机练习 3-1 java语言基础入门 3-2 数据的类 3-3 标识符、关键字和常量 3-4 运算符 3-5 表达式 3-6 顺序结构和选择结构 3-7 循环语句 3-8 跳转语句 3-9 MyEclipse工具介绍 3-10 java基础知识章节练习 4-1 一维数组 4-2 数组应用 4-3 多维数组 4-4 排序算法 4-5 增强for循环 4-6 数组和排序算法章节练习 5-0 抽象和封装 5-1 面向过程的设计思想 5-2 面向对象的设计思想 5-3 抽象 5-4 封装 5-5 属性 5-6 方法的定义 5-7 this关键字 5-8 javaBean 5-9 包 package 5-10 抽象和封装章节练习 6-0 继承和多态 6-1 继承 6-2 object类 6-3 多态 6-4 访问修饰符 6-5 static修饰符 6-6 final修饰符 6-7 abstract修饰符 6-8 接口 6-9 继承和多态 章节练习 7-1 面向对象的析与设计简介 7-2 对象模型建立 7-3 类之间的关系 7-4 软件的可维护与复用设计原则 7-5 面向对象的设计与析 章节练习 8-1 内部类与包装器 8-2 对象包装器 8-3 装箱和拆箱 8-4 练习题 9-1 常用类介绍 9-2 StringBuffer和String Builder类 9-3 Rintime类的使用 9-4 日期类简介 9-5 java程序国际化的实现 9-6 Random类和Math类 9-7 枚举 9-8 练习题 10-1 java异常处理 10-2 认识异常 10-3 使用try和catch捕获异常 10-4 使用throw和throws引发异常 10-5 finally关键字 10-6 getMessage和printStackTrace方法 10-7 异常类 10-8 自定义异常类 10-9 练习题 11-1 Java集合框架和泛型机制 11-2 Collection接口 11-3 Set接口实现类 11-4 List接口实现类 11-5 Map接口 11-6 Collections类 11-7 泛型概述 11-8 练习题 12-1 多线程 12-2 线程的生命周期 12-3 线程的调度和优先级 12-4 线程的同步 12-5 集合类的同步问题 12-6 用Timer类调度任务 12-7 练习题 13-1 Java IO 13-2 Java IO原理 13-3 流类的结构 13-4 文件流 13-5 缓冲流 13-6 转换流 13-7 数据流 13-8 打印流 13-9 对象流 13-10 随机存取文件流 13-11 zip文件流 13-12 练习题 14-1 图形用户界面设计 14-2 事件处理机制 14-3 AWT常用组件 14-4 swing简介 14-5 可视化开发swing组件 14-6 声音的播放和处理 14-7 2D图形的绘制 14-8 练习题 15-1 反射 15-2 使用Java反射机制 15-3 反射与动态代理 15-4 练习题 16-1 Java标注 16-2 JDK内置的基本标注类型 16-3 自定义标注类型 16-4 对标注进行标注 16-5 利用反射获取标注信息 16-6 练习题 17-1 顶目实战1-单机版五子棋游戏 17-2 总体设计 17-3 代码实现 17-4 程序的运行与发布 17-5 手动生成可执行JAR文件 17-6 练习题 18-1 Java数据库编程 18-2 JDBC类和接口 18-3 JDBC操作SQL 18-4 JDBC基本示例 18-5 JDBC应用示例 18-6 练习题 19-1 。。。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值