PAT(甲级)2019年秋季考试 7-2 Merging Linked Lists (C++)

Given two singly linked lists L 1 = a 1 → a 2 → ⋯ → a n − 1 → a n L_1=a_1→a_2→⋯→a_{n−1}→a_n L1=a1a2an1an and L 2 = b 1 → b 2 → ⋯ → b m − 1 → b m L_2=b_1→b_2→⋯→b_{m−1}→b_m L2=b1b2bm1bm. If n ≥ 2 m n≥2m n2m, you are supposed to reverse and merge the shorter one into the longer one to obtain a list like a 1 → a 2 → b m → a 3 → a 4 → b m − 1 ⋯ a_1→a_2→b_m →a_3→a_4→b_{m−1} ⋯ a1a2bma3a4bm1. For example, given one list being 6→7 and the other one 1→2→3→4→5, you must output 1→2→7→3→4→6→5.

Input Specification:

Each input file contains one test case. For each case, the first line contains the two addresses of the first nodes of L 1 L_1 L1 and L 2 L_2 L2, plus a positive N ( ≤ 1 0 5 ) N (≤10^5) N(105) which is the total number of nodes given. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N N N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is a positive integer no more than 1 0 5 10^5 105, and Next is the position of the next node. It is guaranteed that no list is empty, and the longer list is at least twice as long as the shorter one.

Output Specification:

For each case, output in order the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 01000 7
02233 2 34891
00100 6 00001
34891 3 10086
01000 1 02233
00033 5 -1
10086 4 00033
00001 7 -1

Sample Output:

01000 1 02233
02233 2 00001
00001 7 34891
34891 3 10086
10086 4 00100
00100 6 00033
00033 5 -1

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-09-09 13:24:02
// All rights reserved.

#include <iostream>
#include <vector>
#include <unordered_map>

using namespace std;

int main(){
    int head1, head2, n;
    scanf("%d %d %d", &head1, &head2, &n);
    unordered_map<int, pair<int, int>> list;
    vector<pair<int, int>> l1, l2, ans;

    int address, num, next;
    for(int i = 0; i < n; ++i){
        scanf("%d %d %d", &address, &num, &next);

        list[address].first = num;
        list[address].second = next;
    }

    int tmp = head1;
    while(tmp != -1){
        l1.emplace_back(tmp, list[tmp].first);
        tmp = list[tmp].second;
    }

    tmp = head2;
    while(tmp != -1){
        l2.emplace_back(tmp, list[tmp].first);
        tmp = list[tmp].second;
    }

    int len1 = l1.size();
    int len2 = l2.size();

    // first 是地址,second 是数值
    if(len1 > len2){
        int pos1 = 0, pos2 = len2 - 1;

        while(pos2 >= 0){
            ans.push_back(l1[pos1++]);
            ans.push_back(l1[pos1++]);
            ans.push_back(l2[pos2--]);
        }

        while(pos1 < len1) ans.push_back(l1[pos1++]);
    }
    else{
        int pos2 = 0, pos1 = len1 - 1;

        while(pos1 >= 0){
            ans.push_back(l2[pos2++]);
            ans.push_back(l2[pos2++]);
            ans.push_back(l1[pos1--]);
        }

        while(pos2 < len2) ans.push_back(l2[pos2++]);
    }

    for(int i = 0; i < ans.size(); ++i){
        if(i == ans.size() - 1) printf("%05d %d -1\n", ans[i].first, ans[i].second);
        else printf("%05d %d %05d\n", ans[i].first, ans[i].second, ans[i + 1].first);
    }

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值