✖L1-023 输出GPLT (20分)[PTA][奇怪的错误增加了]

24 篇文章 0 订阅

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT....这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL

ac代码:


// gcd lcm有理数
//  main.cpp
//  猫猫头
//
//  Created by Mintink on 2020/1/12.
//  Copyright © 2020 Mintink. All rights reserved.
//

#include<iostream>
#include<string.h>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<set>
#include<numeric>
#include<vector>
#include<queue>
#include<array>
#define _USE_MATH_DEFINES
using namespace std;
typedef long long ll;
//const int mod=10^9+7;
#define inf 0x3f3f3f3f
//tuple<int,int,int>p[100000]
int vis[100100];
int main()
{
    string a;
    cin>>a;
    int g=0,p=0,l=0,t=0;
    for(int i=0;i<a.size();i++)
    {
        if(a[i]=='G'||a[i]=='g')
            g++;
        else if(a[i]=='P'||a[i]=='p')
            p++;
        else if(a[i]=='L'||a[i]=='l')
            l++;
        else if(a[i]=='T'||a[i]=='t')
            t++;
    }
    while(g||p||l||t)
    {
        if(g>0)
        {
            cout<<"G";
            g--;
        }
        if(p>0)
        {
            cout<<"P";
            p--;
        }
        if(l>0)
        {
            cout<<"L";
            l--;
        }
        if(t>0)
        {
            cout<<"T";
            t--;
        }
    }
    return 0;
}


 

错误代码:


// gcd lcm有理数
//  main.cpp
//  猫猫头
//
//  Created by Mintink on 2020/1/12.
//  Copyright © 2020 Mintink. All rights reserved.
//

#include<iostream>
#include<string.h>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<set>
#include<numeric>
#include<vector>
#include<queue>
#include<array>
#define _USE_MATH_DEFINES
using namespace std;
typedef long long ll;
//const int mod=10^9+7;
#define inf 0x3f3f3f3f
//tuple<int,int,int>p[100000]
int vis[100100];
int main()
{
    string a;
    cin>>a;
    int g=0,p=0,l=0,t=0;
    for(int i=0;i<a.size();i++)
    {
        if(a[i]=='G'||a[i]=='g')
            g++;
        else if(a[i]=='P'||a[i]=='p')
            p++;
        else if(a[i]=='L'||a[i]=='l')
            l++;
        else if(a[i]=='T'||a[i]=='t')
            t++;
    }
    while(l)
    {
        if((g==0&&p==0)&&(l==0&&t==0))
            break;
        if(g>0)
        {
            cout<<"G";
            g--;
        }
        if(p>0)
        {
            cout<<"P";
            p--;
        }
        if(l>0)
        {
            cout<<"L";
            l--;
        }
        if(t>0)
        {
            cout<<"T";
            t--;
        }
    }
    return 0;
}

从错误到ac就是(g==0&&p==0)&&(l==0&&t==0)与g||p||l||t的距离

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值