G - Shortest Prefixes POJ - 2001---字典树找唯一最短前缀

第二天叫醒我的不是闹钟,是梦想!

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of “carbon” are: “c”, “ca”, “car”, “carb”, “carbo”, and “carbon”. Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, “carbohydrate” is commonly abbreviated by “carb”. In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.

In the sample input below, “carbohydrate” can be abbreviated to “carboh”, but it cannot be abbreviated to “carbo” (or anything shorter) because there are other words in the list that begin with “carbo”.

An exact match will override a prefix match. For example, the prefix “car” matches the given word “car” exactly. Therefore, it is understood without ambiguity that “car” is an abbreviation for “car” , not for “carriage” or any of the other words in the list that begins with “car”.
Input
The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.
Output
The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.
Sample Input
carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate
Sample Output
carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

//建字典树的时候,用一个res数组记录着,每个节点被走过了多少次。然后分解每个串的前缀去匹配。如果前缀的结尾字符只走过1次,那么一定是前缀输出即可。或者是从来没有建过节点的。如果没有唯一的最短前缀,那只能输出自己

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const int N=1e5+10;
int s[N][26],idx,cnt;
char ch[N][30];
int res[N];
char s1[N];
void insert()
{
  int p=0;
  int l=strlen(ch[cnt]);
  for(int i=0;i<l;i++)
  {
    int u=ch[cnt][i]-'a';
    if(!s[p][u]) s[p][u]=++idx;
    p=s[p][u];
    res[p]++;
  }
}
bool find()
{
  int p=0;
  int l=strlen(s1);
  int f1=true,f2=true;
  for(int i=0;i<l;i++)
  {
    int u=s1[i]-'a';
    if(!s[p][u]) return true;
    p=s[p][u];
  }
  if(res[p]==1) return true;
  return false;
}
int main()
{
    while(gets(ch[++cnt]))
    {
      insert();
    }
    for(int i=1;i<=cnt;i++)
    {
      int l=strlen(ch[i]);
      int f=0;
      for(int j=0;j<l;j++)
      {
        strncpy(s1,ch[i],j+1);
        s1[j+1]='\0';
      //  cout<<s1<<endl;
        if(find()==true) {f=1;cout<<ch[i]<<" "<<s1<<endl;break;}
      }
      if(f==0) {cout<<ch[i]<<" "<<ch[i]<<endl;}
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值