迷宫问题----------------------最短路模型

给定一个 n×n 的二维数组,如下所示:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

数据保证至少存在一条从左上角走到右下角的路径。

输入格式
第一行包含整数 n。

接下来 n 行,每行包含 n 个整数 0 或 1,表示迷宫。

输出格式
输出从左上角到右下角的最短路线,如果答案不唯一,输出任意一条路径均可。

按顺序,每行输出一个路径中经过的单元格的坐标,左上角坐标为 (0,0),右下角坐标为 (n−1,n−1)。

数据范围
0≤n≤1000
输入样例:
5
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
输出样例:
0 0
1 0
2 0
2 1
2 2
2 3
2 4
3 4
4 4

解析:
这道题需要记录路经,需要用一个数组记录前驱。
走过的点不要重复走


#include<bits/stdc++.h>
using namespace std;
#define x first
#define y second
const int N=1005;
int a[N][N];
int dx[4]={0,-1,0,1};
int dy[4]={1,0,-1,0};
bool st[N][N];
typedef pair<int,int> PII;
PII p[N][N];
int n;
void bfs(int x,int y)
{
    queue<PII> q;
    q.push({x,y});
    st[x][y]=true;
    p[x][y]={-1,-1};
    while(q.size())
    {
        auto t=q.front();
        q.pop();
        for(int i=0;i<4;i++)
        {
            int xx=t.x+dx[i];
            int yy=t.y+dy[i];
            if(xx<0||yy<0||xx>=n||yy>=n||a[xx][yy]||st[xx][yy]) continue;
            q.push({xx,yy});
            st[xx][yy]=true;
            p[xx][yy]={t.x,t.y};
        }
    }
}
int main()
{
    cin>>n;
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++) cin>>a[i][j];
    bfs(0,0);
    PII end={n-1,n-1};
    vector<PII> res;
    while(end!=make_pair(-1,-1))
    {
        res.push_back(end);
        end=p[end.x][end.y];
    }
    for(auto it=res.rbegin();it!=res.rend();it++)
    {
        cout<<it->first<<" "<<it->second<<endl;
    }
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值