I was trying to solve problem ‘1234 - Harmonic Number’, I wrote the following code
long long H( int n ) {
long long res = 0;
for( int i = 1; i <= n; i++ )
res = res + n / i;
return res;
}
Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.
Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.
Each case starts with a line containing an integer n (1 ≤ n < 231).
Output
For each case, print the case number and H(n) calculated by the code.
Sample Input
11
1
2
3
4
5
6
7
8
9
10
2147483647
Sample Output
Case 1: 1
Case 2: 3
Case 3: 5
Case 4: 8
Case 5: 10
Case 6: 14
Case 7: 16
Case 8: 20
Case 9: 23
Case 10: 27
Case 11: 46475828386
Sponsor
解析:
求解 f(n)=n/1 +n/2 +n/3+n/4+…n/n
下图是f(n)的函数图,发现y=x这条直线正好使得y=n/x 对称
所以我们只要算到sqrt(n) 然后再*2,再减去sqrt(n)这个点因为多算了一次
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int t;
ll n;
int main()
{
scanf("%d",&t);
int k=0;
while(t--)
{
scanf("%lld",&n);
ll res=0;
int m=sqrt(n);
for(int i=1;i<=m;i++) res+=n/i;
res*=2;
res-=m*m;
printf("Case %d: %lld\n",++k,res);
}
}