LightOJ - 1245 G - Harmonic Number (II)

I was trying to solve problem '1234 - Harmonic Number', I wrote the following code

long long H( int n ) {
    long long res = 0;
    for( int i = 1; i <= n; i++ )
        res = res + n / i;
    return res;
}

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n < 231).

Output

For each case, print the case number and H(n) calculated by the code.

Sample Input

11

1

2

3

4

5

6

7

8

9

10

2147483647

Sample Output

Case 1: 1

Case 2: 3

Case 3: 5

Case 4: 8

Case 5: 10

Case 6: 14

Case 7: 16

Case 8: 20

Case 9: 23

Case 10: 27

Case 11: 46475828386

题意:给一个数n求它除以从1到n的整数解的和

分析:求前n项的n/i 的和只取整数部分,因为n太大容易超时,所以要找规律。比如n=100的话,i=4时n/i等于25,i=5时n/i等于20,所以大于20到小于等于25内的5个数字j都有n/j等于4,然后sum+=4*5所以我们可以在小于等于根号n的范围内枚举i,sum+=n/i,然后sum+=(n/(i)-n/(i+1))*i,最后还需要判断是否有 n/i=i 这种情况,需要减去i

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
typedef long long ll;
int main()
{
    int t,v=1;
    scanf("%d",&t);
    while(t--)
    {
        ll n,sum=0,k;
        scanf("%lld",&n);
        k=sqrt(n);
        for(ll i=1;i<=k;i++)
        {
            sum+=(n/i-n/(i+1))*i+n/i;
            if(n/i==i)
                sum-=i;
        }
        printf("Case %d: %lld\n",v++,sum);
    }
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值