1003 Emergency (25 分)题解(Dijkstra算法)详细注释

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output
For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:
5 6 0 2

1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output:
2 4
此题的关键就在于用Dijkstra算法更新路径时,起点到某节点的路径条数也要更新,并且路径长度相等时还要判断哪条路径上救援团队更多。

#include <iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int n,m,c1,c2;//点,边,当前,目的
int arcs[510][510],weight[510],dis[510],num[510],team[510];//矩阵,点权,边权,num[i]表示从出发点到i结点最短路径的条数,w[i]表示从出发点到i点救援队的数目之和
bool visit[510];//访问
const int inf=999999;//极大值成最小值
int main()
{
    scanf("%d%d%d%d",&n,&m,&c1,&c2);//初始化
    for(int i=0;i<n;i++)
        scanf("%d",&weight[i]);
    fill(arcs[0],arcs[0]+510*510,inf);//矩阵边权全极大
    fill(dis,dis+510,inf);
    int a,b,c;
    for(int i=0;i<m;i++){
         scanf("%d%d%d",&a,&b,&c);
         arcs[a][b]=arcs[b][a]=c;
    }
    dis[c1]=0;//到自己的距离为0
    team[c1]=weight[c1];
    num[c1]=1;
    for(int i=0;i<n;i++){//开始大循环,逐点更新
        int u=-1,minn=inf;//u是离出发结点最近的结点也是之后的中间结点
        for(int j=0;j<n;j++){//逐点找离出发点最小的结点
            if(!visit[j]&&dis[j]<minn){
            u=j;
            minn=dis[j];
            }
        }
    if(u==-1) break;
    visit[u]=true;//最近结点已找到
    for(int v=0;v<n;v++){//逐点找是否可以更新距离的结点
        if(!visit[v]&&arcs[u][v]!=inf){
            if(dis[u]+arcs[u][v]<dis[v]){//可更新
                dis[v]=dis[u]+arcs[u][v];
                num[v]=num[u];             
                team[v]=team[u]+weight[v];
            }
            else if(dis[u]+arcs[u][v]==dis[v]){
                num[v]=num[v]+num[u];
                if(team[u]+weight[v]>team[v])
                    team[v]=team[u]+weight[v];
            }
        }
    }
    }
    printf("%d %d",num[c2],team[c2]);
    return 0;
}

参考代码:https://blog.csdn.net/liuchuo/article/details/52300668
博主柳神,大力推荐她的文章。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值