【eNSP 华为模拟器】小型校园网模拟环境的设计与配置

一、实验概述

按照以下的拓扑连接,自行设计VLAN和IP地址等网络参数,实现PC1到PC2的IP通信。其中,R1,R2为路由器;LSW1,LSW4为3层交换机;LSW2,LSW3 ,LSW6, LSW7为2层交换机;CLIENT1-CLIENT12为PC机。
拓扑图
在这里插入图片描述

课程设计要求:(1)IP地址自行规划设计,应该清晰地列出图表,并在拓扑图上标出,以备老师检查时使用。(2)路由器之间使用广域网接口S口连接,其余设备与设备,设备与PC之间使用以太网口连接。
请规划好相应的参数,图表列出,并在拓扑图上标识。
在这里插入图片描述要求:
按照拓扑连接好,并配置VLAN端口划分,然后配置TRUNK参数,最后配置3层交换机的路由端口,以及路由器的各个端口参数,能够确保VLAN间通信节点通信的顺利进行。

实验环境
在这里插入图片描述
依据实验要求,计划设置八个VLAN,分别是:
在这里插入图片描述
VLAN10(LSW1) 和VLAN10(LSW2)创建的原因:需要给两个三层交换机的出口配置IP地址,但由于交换机的端口不能直接设置IP地址,只能将交换机端口划入vlan,然后给这个vlan interface 设置IP地址。

二、交换机的配置

2.1 二层交换机的配置

二层交换机上配置过程的思想:以二层交换机LSW7为例,其他二层交换机的配置同理。需要要在LSW7上划分VALN。首先,进入交换机的全局配置模式,建立VLAN100、VLAN200、VLAN300,将e0/0/1口、e0/0/2口、e0/0/3口一起设置为access模式并依次分给VLAN100、VLAN200、VLAN300。然后,将二层交换机出口e0/0/4口设置为trunk模式,并允许所有的vlan通过。

二层交换机的配置命令如下:

<Switch7>sys
[Switch7]undo info-center enable  //关闭消息提示
[Switch7]vlan batch 100 200 300
Info: This operation may take a few seconds. Please wait for a moment...done.
[Switch7]interface Ethernet0/0/1
[Switch7-Ethernet0/0/1]port link-type access 
[Switch7-Ethernet0/0/1]port default vlan 100

[Switch7]interface Ethernet0/0/2
[Switch7-Ethernet0/0/2]port link-type access 
[Switch7-Ethernet0/0/2]port default vlan 200

[Switch7]interface Ethernet0/0/3
[Switch7-Ethernet0/0/3]port link-type access 
[Switch7-Ethernet0/0/3]port default vlan 300

[Switch7]interface Ethernet0/0/4
[Switch7-Ethernet0/0/4]port link-type trunk 
[Switch7-Ethernet0/0/4]port trunk allow-pass vlan all

2.2 三层交换机的配置

三层交换机上配置过程的思想:以三层交换机LSW2为例,其他三层交换机的配置同理。首先,需要要在LSW2上划分VALN;进入交换机的全局配置模式,建立VLAN100、VLAN200、VLAN300;依次进入VLAN内部配置VLAN的IP地址为VLAN所在的网段。然后,将三层交换机与二层交换机之间的接口g0/0/1和g0/0/2设置为trunk模式,并允许所有的vlan通过。为了给g0/0/3配置一个IP地址,先创建一个VLAN10,分配给g0/0/03,设置模式为access,然后给Vlan10配置IP地址。接着,为三层交换机开启OSPF路由,建立一个区域0,宣告网络。

三层交换机的配置命令如下:

<Switch2>sys
[Switch2]undo info-center enable  //关闭消息提示
[Switch2]vlan batch 100 200 300
Info: This operation may take a few seconds. Please wait for a moment...done.
[Switch2]int vlanif 100
[Switch2-Vlanif100]ip address 192.168.1.1 24
[Switch2]int vlanif 200
[Switch2-Vlanif200]ip address 192.168.2.1 24
[Switch2]int vlanif 300
[Switch2-Vlanif300]ip address 192.168.3.1 24
[Switch2]int g0/0/1
[Switch2-GigabitEthernet0/0/1]port link-type trunk 
[Switch2-GigabitEthernet0/0/1]port trunk allow-pass vlan all
[Switch2]int g0/0/2
[Switch2-GigabitEthernet0/0/2]port link-type trunk 
[Switch2-GigabitEthernet0/0/1]port trunk allow-pass vlan all

[Switch2]vlan 10
[Switch2]int g0/0/3
[Switch2- GigabitEthernet 0/0/3]port link-type access 
[Switch2 GigabitEthernet 0/0/3]port default vlan 10
[Switch2]int vlanif 10
[Switch2-lanif10]ip address 172.16.3.1 24

[Switch2]ospf
[Switch2-ospf-1]area 0
[Switch2-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
[Switch2-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
[Switch2-ospf-1-area-0.0.0.0] network 192.168.3.0 0.0.0.255
[Switch2-ospf-1-area-0.0.0.0] network 172.16.3.0 0.0.0.255

三、路由器的配置

路由器上配置过程的思想:以路由器R2为例,其他路由器的配置同理。首先,需要给e0/0/0口和s0/0/0口配置IP地址;然后启动ospf协议,并宣告网络。

路由器的配置命令如下

[R2]int e0/0/0
[R2-Ethernet0/0/0]ip address 172.16.3.2
[R2-Ethernet0/0/0]int s0/0/0
[R2-Serial0/0/0]ip address 172.16.2.2 24
[R2]ospf
[R2-ospf-1]area 0
[R2-ospf-1-area-0.0.0.0]network 172.16.3.0 0.0.0.255
[R2-ospf-1-area-0.0.0.0]network 172.16.2.0 0.0.0.255

四、实验结果

经过上述的配置,跨交换机路由器的校园网模拟环境的设计与配置就已经完成了。
以下是IP通信的截图
测试三层交换机的配置。从PC1 ping PC4和PC6,都不需要经过路由器,只需要经过三层交换机,证明三层交换机的配置成功。
在这里插入图片描述
测试路由器的配置,证明ospf的配置过程,从PC2 ping 到PC10,成功ping通,如下图。
在这里插入图片描述
从PC7上跟踪路由到PC2,用命令tracert 192.168.2.50。可以查询从PC7到PC2所在的电脑要经过的路由器及其IP地址。下图中的红色箭头表示了路由的过程。
在这里插入图片描述
自此,该拓扑中任意的PC机都可以与其他的PC机交互,验证通信完毕。

五、实验总结

通过这次实验我掌握了华为设备下三层交换机划分vlan以及vlan间的通信等知识。在实验过程中遇到的一个问题是:当我配置完ospf后,PC1只能ping到三层交换机的出口,无法连接到路由器与三层交换机的接口;后来经同学指出,原来我的三层交换机给ospf宣告网络的时候忘记把PC1等所在的VLAN的网段宣告进去,毕竟从PC1到三层交换机出口的网段已经算是跨网段了。这段小错误的经历也让我对OSPF的配置有了更深的理解。

eNSP文件下载
【eNSP 华为模拟器】小型校园网模拟环境的设计与配置.rar下载

展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客
应支付0元
点击重新获取
扫码支付

支付成功即可阅读