HDUOJ 1045 Fire Net

HDUOJ 1045 Fire Net

题目链接

Problem Description

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.’ indicating an open space and an uppercase ‘X’ indicating a wall. There are no spaces in the input file.

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample Input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample Output

5
1
5
2
4

典型的二分图匹配,考虑缩进点建图,如图:
在这里插入图片描述
如果有墙隔开,则行数或列数加一,再套一个最大匹配的模板即可:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=20;
int g[N][N],match[N],vis[N],r[N][N],c[N][N],cnt1,cnt2;
int n,x,y,k;
char m[N][N];
int found(int x){
    for(int i=1;i<=cnt2;i++){
        if(g[x][i] && !vis[i]){
            vis[i]=1;
            if(!match[i] || (found(match[i]))){
                match[i]=x;
                return 1;
            }
        }
    }
    return 0;
}

void hungary(){
    int ans=0;
    fill(match,match+N,0);
    for(int i=1;i<=cnt1;i++){
        fill(vis,vis+N,0);
        if(found(i)) ans++;
    }
    printf("%d\n",ans);
}

int main(){
    while(scanf("%d",&n) && n){
        fill(g[0],g[0]+N*N,0);
        fill(r[0],r[0]+N*N,0);
        fill(c[0],c[0]+N*N,0);
        for(int i=1;i<=n;i++)
            scanf("%s",m[i]+1);
        cnt1=1;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                if(m[i][j]=='X' && j+1<=n && m[i][j+1]!='X') cnt1++;
                else r[i][j]=cnt1;
            }
            if(i<n) cnt1++;
        }
        cnt2=1;
        for(int j=1;j<=n;j++){
            for(int i=1;i<=n;i++){
                if(m[i][j]=='X' && i+1<=n && m[i+1][j]!='X') cnt2++;
                else c[i][j]=cnt2;
            }
            if(j<n) cnt2++;
        }
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++)
                if(m[i][j]=='.') g[r[i][j]][c[i][j]]=1;
        }
        hungary();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旺 崽

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值