HDUOJ 2859 Phalanx

HDUOJ 2859 Phalanx

题目链接

Problem Description

Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC.
A phalanx is a matrix of size n ∗ n n*n nn, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position.
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs.
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3*3 symmetrical matrix:
cbx
cpb
zcc

Input

There are several test cases in the input file. Each case starts with an integer n (0<n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.

Output

Each test case output one line, the size of the maximum symmetrical sub- matrix.

Sample Input

3
abx
cyb
zca
4
zaba
cbab
abbc
cacq
0

Sample Output

3
3

题意太迷了,我看了半天,发现是求最大对称子矩阵的边长,对称轴为左下角到右下角的那条对角线,用 d p [ i ] [ j ] dp[i][j] dp[i][j] 表示第 i i i 行第 j j j 列的最大子矩阵的边长,那么就有状态转移方程:
d p [ i ] [ j ] = m a x ( d p [ i ] [ j ] , d p [ i − 1 ] [ j + 1 ] + 1 ) dp[i][j]=max(dp[i][j],dp[i-1][j+1]+1) dp[i][j]=max(dp[i][j],dp[i1][j+1]+1)
AC代码如下:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=1e3+5;
int dp[N][N],ans,n;
char s[N][N];
int main(){
    while(~scanf("%d",&n)&&n){
        ans=1;
        for(int i=0;i<n;i++) scanf("%s",s[i]);
        for(int i=0;i<n;i++) for(int j=0;j<n;j++) i?dp[i][j]=0:dp[i][j]=1;
        for(int i=0;i<n;i++){
            for(int j=0;j<n;j++){
                if(i==0) continue;
                int x=i,y=j;
                while(x>=0&&y<n&&s[x][j]==s[i][y]){
                    x--,y++;
                }
                int change=i-x;
                if(change>=dp[i-1][j+1]+1) dp[i][j]=dp[i-1][j+1]+1;
                else dp[i][j]=change;
                ans=max(ans,dp[i][j]);
            }
        }
        printf("%d\n",ans);
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旺 崽

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值