1121 Damn Single(Why not be a gay?)

Single dog, single dog, single everyday.

See AV, hit the plane, they're doing all day.

Hey! Single dog, single dog, why not be a gay?

No more wait, no more afraid, make yourself a gay.

 "Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:

5
10000 23333 44444 55555 88888
#include<iostream>
#include<vector>
#include<set>
using namespace std;
int main()
{
    int n,a,b,m;
    cin>>n;
    vector<int>couple(100000,-1);
    for (int i=0; i<n; i++)
    {
        cin>>a>>b;
        couple[a]=b;
        couple[b]=a;
    }
    cin>>m;
    vector<int>guest(m),isExist(100000,0);
    for (int i=0; i<m; i++)
    {
        cin>>guest[i];
        if (couple[guest[i]]!=-1)///If is the one of the couple.
            isExist[couple[guest[i]]]=1;///TA's boyfriend or girlfriend is 1
    }
    set<int> s;
    for (int i=0; i<m; i++)
    {
        if (isExist[guest[i]]!=1)
            s.insert(guest[i]);
    }
    cout<<s.size()<<endl;
    for (auto it=s.begin(); it!=s.end(); it++)
    {
        if (it!=s.begin())
            cout<<" ";
        printf("%05d", *it);///Pay attention to the format!!!
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值