Super Jumping! Jumping! Jumping! HDU - 1087 (最长不下降【上升】子序列的和)你绝对能看懂的动态规划!!!!

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now. 
The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path. 
Your task is to output the maximum value according to the given chessmen list. 

Input

Input contains multiple test cases. Each test case is described in a line as follow: 
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. 
A test case starting with 0 terminates the input and this test case is not to be processed. 

Output

For each case, print the maximum according to rules, and one line one case. 

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3
#include<stdio.h>
#include<iostream>
using namespace std;
int n,a[1988],dp[1988],i,j;
int main()
{
    while(cin>>n&&n)
    {///不断输入直到n=0停止
        for(i=1; i<=n; i++)
            cin>>a[i];///输入序列
            int ans=-0xffff;///一定要放在循环里面,否则会WA!!!
        for(i=1; i<=n; i++)
        {
///该动规的边界,如果之前的元素都比a[i]大,a[i]就自己形成序列,和为a[i];
            dp[i]=a[i];
            for(j=1; j<i; j++)
            {///a[i]之前的元素
                if(a[j]<a[i])///存在使序列变长得值
///关键所在,状态转移方程:2种情况,就看哪个值大就是哪种
///1.a[i]一个元素形成序列2.a[i]加到之前形成的序列,使序列更长
///第一种情况一定得是dp[i],如果是a[i]会WA!!!
                dp[i]=max(dp[i],dp[j]+a[i]);
            }
            ans=max(ans,dp[i]);///找出所有上升序列和的最大者
        }
        cout<<ans<<endl;
    }
}
inline char gc()
{
    static char buff[100000000],*S=buff,*T=buff;
    return S==T&&(T=(S=buff)+fread(buff,1,100000000,stdin),S==T)?EOF:*S++;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值