1024 Palindromic Number (25 分)燚

1024 Palindromic Number (25 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​10​​) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

题目大意:输入两个数N和K,1.N=N+N的倒序。如果N为回环数则输出回环数结果,否则继续重复1操作,重复次数小于K。

思路:1.由于涉及N的倒序,所以选择用string更为方便,可调用vector<string>temp(s.rbegin(),s.rend());获得s的倒序,比起用int类型 连续求余相加方便的多。

            2.因为重复N=N+N的倒序操作,因此选择用递归思想,结束条件为  N为回环数,或者重复次数大于K。

坑点:输入的N值本身就是一个回环数,不需要变换。此时变换次数为0.

难点:涉及到int 转char类型。在某些编译器下可能_itoa()函数会报错。解决办法:用string 代替char。即int转string,调用to_string(val).

#include<iostream>
#include<string>
#include<stack>
using namespace std;

//检测自身是否为回环数
bool checkSelf(string &number) {
	string temp(number.rbegin(), number.rend());   //求number的倒序
	bool flag = true;
	if(temp!=number)
		return false;
	return true;
}

//N=N+N的倒序
void change(string  &number, int &changeNum, int n) {
	 //检测自身是否是个回环数
	bool flag = checkSelf(number);  
	if (flag)
		return;
	 //检测转换次数是否达到上限n次
	if (changeNum == n )     
		return;
    

    //如果以上条件不成立  执行N=N+N的倒序
	int t = 0;
	string temp(number.rbegin(), number.rend());
	stack<string>result;
	//求N=N+N的倒序,并将结果逐位压入栈中
	for (int i = number.size() - 1; i >= 0; i--) {
		string x = (to_string((int(number[i] - '0') + int(temp[i] - '0') + t) % 10 ));
		t = (int(number[i] - '0') + int(temp[i] - '0') + t) / 10;
		result.push(x);
	}
	//如果最高位相加大于10,将进位压入栈中
	if (t == 1)  
		result.push("1");

	//更新number为相加后的和
	number.clear();
	while (!result.empty()) {
		string temp = result.top();
		number += temp;
		result.pop();
	}

	change(number, ++changeNum, n);

}

int main() {
	string number;
	int n;
	cin >> number >> n;
	int changeNum = 0;//开始的变换次数为0.
	change(number, changeNum, n);
	cout << number << endl;
	cout << changeNum << endl;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值