PAT1004

46 篇文章 0 订阅

原题

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

题意:一个家庭的层级结构经常被表现为一个家谱树。你的任务是统计这些家庭成员中谁没有孩子。

输入:每个测试案例由N开始,表示有N个节点,接下来是M,表示非叶子节点个数,然后后面有M行,每行有如下格式:

ID 表示非叶子节点,K表示这个非叶子节点下的子孙数目,接下来的ID[1]……都是表示当前ID的子孙节点。根节点为01。

输出:输出每一层的叶子结点的个数。

思路

一开始想着构建一颗二叉树,直接bfs,发现好像不太好实现。仔细想下,好像也没这个必要。

创建一个二维数组,每个数组的第一维表示非叶子节点个数,第二维表示这个非叶子节点下的子孙节点。

如果没有第二维度,说明这个节点没有子孙节点,也就说明这个节点是叶子节点。

统计每一层的叶子节点个数,保存起来,输出即可。

题解

#include <algorithm>
#include <iostream>
#include <queue>
#include <vector>

using namespace std;

int main() {
  vector<int> vec[100];
  vector<int> ans(100, 0);
  int n, m, node, k, c;
  cin >> n >> m;
  for (int i = 0; i < m; ++i) {
    cin >> node >> k;
    for (int j = 0; j < k; ++j) {
      cin >> c;
      vec[node].emplace_back(c);
    }
  }
  int cnt = 0, depth = 0;
  queue<int> que;
  que.push(1);
  while (!que.empty()) {
    ++depth;
    int size = que.size();
    for (int i = 0; i < size; ++i) {
      int val = que.front();
      que.pop();
      if (vec[val].size() == 0) {
        ++cnt;
      } else {
        for (int j = 0; j < (int)vec[val].size(); ++j) {
          que.push(vec[val][j]);
        }
      }
    }
    ans[depth - 1] = cnt;
    cnt = 0;
  }
  for (int i = 0; i < depth - 1; ++i) {
    cout << ans[i] << " ";
  }
  cout << ans[depth - 1] << endl;
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值