PAT 甲级1099

1099 Build A Binary Search Tree (30 分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:
58 25 82 11 38 67 45 73 42

题目:第一行数字N,接下来N行,每行两个数字,第i行的两个数字表示第i个的节点的左右孩子的编号,最后一行N个数字表示需要建树的数字,结果按照行的bfs输出。

思路:按照输入建立树,然后按照中序遍历的方式把数字填入树中,然后bfs完成输出

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<queue>
using namespace std;
struct node{
	int ID,data,Lchild,Rchild;
};
int cursor,N;
node tree[100];
int num[100];
void midorder(int i){
	if(tree[i].Lchild>=0)midorder(tree[i].Lchild);
	tree[i].data=num[cursor++];
	if(tree[i].Rchild>=0)midorder(tree[i].Rchild);
}
void bfs()
{
	int cur;
	queue<int>q;
	q.push(0);
	while(q.size()!=0)
	{
		cur=q.front();
		q.pop();
		if(tree[cur].Lchild>=0)q.push(tree[cur].Lchild);
		if(tree[cur].Rchild>=0)q.push(tree[cur].Rchild);
		if(cur!=0)cout<<" ";
		cout<<tree[cur].data;
	}
}
int main()
{
	int i,j,k;
	freopen("input.txt","r",stdin);
	cin>>N;
	for(i=0;i<N;i++)
	{
		cin>>j>>k;
		tree[i].ID=i;
		tree[i].Lchild=j;
		tree[i].Rchild=k;
	}
	for(i=0;i<N;i++)
	{
		cin>>j;
		num[i]=j;
	}
	sort(num,num+N);
	midorder(0);
	bfs();
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值