[POJ-2253] Frogger【dijkstrra】

Frogger

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 64734 Accepted: 20103
Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.
Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output

For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414
Source

Ulm Local 1997

链接:http://poj.org/problem?id=2253

简述:有一条小河,河里有两只青蛙a、b。a在石头1上,b在石头2上,已知河里一共有n块石头,编号为1~n,已知所有石头的坐标。求青蛙a到青蛙b的位置所需最小跳跃距离。

分析:先预处理一下vis数组,输入数据【结构体储存横纵坐标】,建无向图,进入dijkstrra算法,但是要注意,这里求的是a到b所有石头路径上的最大边的值,所以松弛(更新)操作要变一下形。

说明:求两点之间距离以及储存距离数据时用double类型。最后保留小数点后三位输出。

AC代码如下:

#include <iostream>
#include <string.h>
#include <algorithm>
#include <cmath>
#include <stdio.h>
#define INF 1e6;
using namespace std;
struct node {
	int x, y;
}s[210];
double d(node a, node b) {	//类型转换
	return sqrt((double)((a.x - b.x)*(a.x - b.x) + (a.y - b.y)*(a.y - b.y)));
}
double map[210][210];	//double类型
double dis[210];
int vis[210];
int n;
void dijkstra() {
	int i, j;
	for (i = 1; i <= n; i++) dis[i] = i == 1 ? 0 : INF;
	for (i = 1; i <= n; i++) {
		int k;
		double minn = INF;
		for (j = 1; j <= n; j++)
			if (!vis[j] && dis[j] <= minn) {
				k = j;
				minn = dis[j];
			}
		vis[k] = 1;
		for (j = 1; j <= n; j++)
			dis[j] = min(dis[j], max(dis[k], map[k][j]));
	}

}
int main()
{
	int i, j, t=0;
	while (cin >> n && n) {
		memset(vis, 0, sizeof(vis));
		for (i = 1; i <= n; i++)
			cin >> s[i].x >> s[i].y;
		for (i = 1; i <= n; i++)	//建无向图
			for (j = 1; j <= n; j++)
				map[i][j] = map[j][i] = d(s[i], s[j]);	//一个点到另一个点之间的距离
		dijkstra();
		printf("Scenario #%d\nFrog Distance = %.3f\n\n", ++t, dis[2]);
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值