1.27-b

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, …, n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line 1 0 1 2 0 0. The maximum total number of marbles will be 20000.
The last line of the input file will be 0 0 0 0 0 0’’; do not process this line. Output
For each colletcion, output Collection #k:’’, where k is the number of the test case, and then eitherCan be divided.’’ or ``Can’t be divided.’’.
Output a blank line after each test case.
Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0
Sample Output
Collection #1:
Can’t be divided.
Collection #2:
Can be divided.
多重背包问题,要用到二进制优化,不然会超时。

#include <iostream>
	using namespace std;
	int max(int a, int b)
	{
		return (a > b ? a : b);
	}
	int main()
	{
		int val[6]; int t = 1;
		while (1)
		{
			int k,sum, p[100000]; k =sum= 0;
			for (int i = 0; i < 6; i++)
			{	
				int c = 1;
				cin >> val[i];
				sum += val[i] * (i + 1);
					if (val[i] == 0)continue;
				while (val[i] > c)///二进制优化
				{
					val[i] -= c;
					p[++k] = (i + 1)*c;
					c *= 2;
				}
				p[++k] = (i + 1)*val[i]; 将剩余的数也存进数组
			}	
			if (sum==0)break;				
			int dp[100000] = { 0 }; 
			if (sum & 1)///如果是奇数就一定不能平分
			{
			cout << "Collection #" << t << ":" << endl;
			cout << "Can't be divided." << endl << endl;
			t++;
			continue;
			}
			for (int i = 1; i <=k; i++)///转换为01背包问题
			{
				for (int j =sum / 2; j >=p[i]  ; j--)
				{
					dp[j] = max(dp[j], dp[j - p[i]] + p[i]);
				}
			
			} 
			if ( dp[sum/2]!=sum/2)
			{
				cout << "Collection #" << t << ":" << endl;
				cout << "Can't be divided." << endl << endl;
			}
			else
			{
				cout << "Collection #" << t << ":" << endl;
				cout<<"Can be divided." << endl << endl;
			}
			t++;
		} 
	}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
693f3c83140151a953a420772ddb9e FAILED https://packages.cloud.google.com/yum/repos/kubernetes-el7-x86_64/Packages/693f3c83140151a953a420772ddb9e4b7510df8ae49a79cbd7af48e82e7ad48e-kubectl-1.27.3-0.x86_64.rpm: [Errno 14] curl#7 - "Failed to connect to 2404:6800:4012:3::200e: Network is unreachable" 正在尝试其它镜像。 413f2a94a2f6981b36bf46ee01ade9 FAILED https://packages.cloud.google.com/yum/repos/kubernetes-el7-x86_64/Packages/413f2a94a2f6981b36bf46ee01ade9638508fcace668d6a57b64e5cfc1731ce2-kubeadm-1.27.3-0.x86_64.rpm: [Errno 14] curl#7 - "Failed connect to packages.cloud.google.com:443; Connection refused" 正在尝试其它镜像。 484ddb88e9f2aaff13842f2aa73017 FAILED https://packages.cloud.google.com/yum/repos/kubernetes-el7-x86_64/Packages/484ddb88e9f2aaff13842f2aa730170f768e66fd4d8a30efb139d7868d224fcf-kubelet-1.27.3-0.x86_64.rpm: [Errno 14] curl#7 - "Failed connect to packages.cloud.google.com:443; Connection refused" 正在尝试其它镜像。 0f2a2afd740d476ad77c508847bad1 FAILED https://packages.cloud.google.com/yum/repos/kubernetes-el7-x86_64/Packages/0f2a2afd740d476ad77c508847bad1f559afc2425816c1f2ce4432a62dfe0b9d-kubernetes-cni-1.2.0-0.x86_64.rpm: [Errno 14] curl#7 - "Failed connect to packages.cloud.google.com:443; Connection refused" 正在尝试其它镜像。 693f3c83140151a953a420772ddb9e FAILED https://packages.cloud.google.com/yum/repos/kubernetes-el7-x86_64/Packages/693f3c83140151a953a420772ddb9e4b7510df8ae49a79cbd7af48e82e7ad48e-kubectl-1.27.3-0.x86_64.rpm: [Errno 14] curl#7 - "Failed connect to packages.cloud.google.com:443; Connection refused" 正在尝试其它镜像。
最新发布
07-14

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值