POJ 1032 Parliament

Description

New convocation of The Fool Land’s Parliament consists of N delegates. According to the present regulation delegates should be divided into disjoint groups of different sizes and every day each group has to send one delegate to the conciliatory committee. The composition of the conciliatory committee should be different each day. The Parliament works only while this can be accomplished.
You are to write a program that will determine how many delegates should contain each group in order for Parliament to work as long as possible.

Input

The input file contains a single integer N (5<=N<=1000 ).

Output

Write to the output file the sizes of groups that allow the Parliament to work for the maximal possible time. These sizes should be printed on a single line in ascending order and should be separated by spaces.

Sample Input

7

Sample Output

3 4

思路:就是说拆分一个整数,使得拆开的数的乘积最大。
考虑一个数,只要能拆成两个大于1的数,则乘积一定大于等于原来的数。所以我们希望将它全部拆成2(或者n个2和1个3),但因为数字不能重复,所以对任意一个数,我们希望将它拆成以2开头的连续数列,最后剩余的数从大到小补到前面。

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <vector>
#include <map>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <cstdlib>

using namespace std;

int main(void)
{
    #ifdef LOCAL
        freopen("in.txt","rb",stdin);
        //freopen("out.txt","wb",stdout);
    #endif // LOCAL
    int n,s[1000];
    scanf("%d",&n);
    int l;
    for(l=2;n>=l;l++)
    {
        n-=l;
        s[l]=l;
    }
    l--;
    for(int i=2;i<=l;i++)
        s[i]+=n/(l-2+1);
    n=n%(l-2+1);
    for(int i=l;i>=l-n+1;i--)
        s[i]+=1;
    for(int i=2;i<=l;i++)
    {
        cout << s[i];
        if(i!=l) cout << ' ';
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值