PAT (Advanced Level) 1031 Hello World for U (20分)JAVA实现

在这里插入图片描述

Sample Input:

helloworld!

Sample Output:

h !
e d
l l
lowor



import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		String str = sc.nextLine();
		int n = str.length();
		int n1=0;
		int n2=n;
		for (int i = 2; i < n; i++) {
			n2=n+2-2*i;
			if(n2<i) {
				i--;
				n1=i;
				n2=n+2-2*i;
				break;
			}
		}
		//System.out.println(n1+" "+n2);
		int space = n2-2;
		int head = 0;
		int tail =str.length()-1;
		n1--;
		int next = 0;
		while(n1-->0) {
			System.out.print(str.charAt(head));
			for (int i = 0; i < space; i++) {
				System.out.print(" ");
			}
			System.out.println(str.charAt(tail));
			head++;
			tail--;
			
		}
		
		//System.out.println("head:"+head+"  n2:"+n2);
		for (int i = head; i < n2+head; i++) {
			System.out.print(str.charAt(i));
		}
	}
	
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值