PAT (Advanced Level) 1031 Hello World for U (20 分)

1031 Hello World for U (20 分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

Code:

#include <iostream>
#include <string>
#include <iomanip>

using namespace std;

int main()
{
	string s;
	cin >> s;
	string sa[3];
	int m = s.length() / 3;
	switch (s.length() % 3)
	{
	case 0:
		sa[0] = s.substr(0, m - 1);
		sa[1] = s.substr(m - 1, m + 2);
		sa[2] = s.substr(2 * m + 1, m - 1);
		break;
	case 1:
		sa[0] = s.substr(0, m);
		sa[1] = s.substr(m, m + 1);
		sa[2] = s.substr(2 * m + 1, m);
		break;
	case 2:
		sa[0] = s.substr(0, m);
		sa[1] = s.substr(m, m + 2);
		sa[2] = s.substr(2 * m + 2, m);
		break;
	default:
		break;
	}
	for (int i = 0; i < sa[0].length(); i++)
	{
		cout << sa[0][i] << setw(sa[1].length() - 1) << setfill(' ') << sa[2][sa[2].size() - i - 1] << endl;
	}
	for (int i = 0; i < sa[1].length(); i++)
	{
		cout << sa[1][i];
	}
	cout << endl;
	return 0;
}

思路

这题是要分类讨论,按字符串长度N被3除后的余数分类,一共三类:0,1,2。
假设N = 3m (m is postive int),
因为 n1 + n2 + n3 = N + 2 = 3m + 2
而且 n1 = n3 <= n2
所以 3m + 2 <= 3n2
所以 n2>= m + 2/3
所以 n1 + n3 + m + 2/3 < 3m + 2
所以 n1 = n3 <= m + 2/3
又因为 n1,n3取最大值
所以 n1 = n3 = m
所以 n2 = m + 2
为了输出方便把N + 2这多处来的2分给n2
实际上字符串1和3长度为m - 1,字符串2长度为m + 2
其他两种情况同理

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值