1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.
Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.
Sample Input:

2 1
01 1 02

Sample Output:

0 1

//19分
#include<vector>
#include<bits/stdc++.h>
using namespace std;
int depth[210];//节点深度
vector<int> v[210];//每个节点的叶子节点
int n;//树的节点数量
int m;//非叶节点数
int main()
{
    depth[1] = 1;
    cin>>n>>m;
    for(int i = 0;i<m;i++)
    {
        int id;
        int k;
        cin>>id>>k;
        for(int i = 0;i<k;i++)
        {
            int temp;
            cin>>temp;
            v[id].push_back(temp);
            depth[temp] = depth[id]+1;
        }
    }
    int max_depth = *max_element(depth+1,depth+n+1);
    for(int i = 1;i<=max_depth;i++)
    {
        int num = 0;
        for(int j = 1;j<=n;j++)
        {
            if(depth[j] == i&&v[j].size() == 0)
            {
                num++;
            }
        }
        if(i == 1)
        {
            cout<<num;
        }
        else
            cout<<" "<<num;
    }
    return 0;
}

//一层一层的进行统计:使用BFS(横向搜索)
#include<bits/stdc++.h>
using namespace std;
vector<int> v[500];//每个节点的叶子节点
int n;//树的节点数量
int m;//非叶节点数
int height[500];
void bfs(int x,int h)
{
    if(!v[x].size())
    {
        height[h]++;
    }
    for(unsigned int i = 0;i<v[x].size();i++)
    {
        bfs(v[x][i],h+1);
    }
}

int main()
{
    cin>>n>>m;
    for(int i = 0;i<m;i++)
    {
        int id;
        int k;
        cin>>id>>k;
        for(int i = 0;i<k;i++)
        {
            int temp;
            cin>>temp;
            v[id].push_back(temp);
        }
    }
    bfs(1,1);//根节点编号:1;深度:1
    int depth = 0;
    for(int i = 400;i>=1;i--)
    {
        if(height[i])
        {
            depth = i;
            break;
        }
    }
    for(int i = 1;i<=depth;i++)
    {
        if(i!=1)
        {
            cout<<" "<<height[i];
        }
        else
            cout<<height[i];
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值