C - Fliptile (黑白棋翻转经典题型 DFS)

C - Fliptile

 

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M× N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N 
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

题意:有一个n*m的棋盘,0表示白色,1表示黑色。每次可以翻转当前位置,它的上下左右四个位置也会被相应翻转。问最少翻转多少次会使所有棋面显示为白色,并给出需要翻转的位置,0表示不翻转,1表示翻转。

思路:可以利用第一层的 2^n 种状态来进行枚举。依次翻转到最后一行,如果最后一行均为白色,那么这种第一层状态可以达到效果。记录下来,最后取最少翻转次数的结果输出。具体实现细节和相关解释在代码注释中给出。

ps:(学到了利用二进制进行枚举的方便之处)QAQ~

代码如下:
原文:https://blog.csdn.net/qq_28300479/article/details/51882675 

 


//Full of love and hope for life

#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <stdio.h>
#include <queue>
#include <map>

using namespace std;

int Map[20][20],cal[20][20],out[20][20];
int n,m;
int dir[5][2] = {{0,0},{0,1},{0,-1},{1,0},{-1,0}};

int fuc(int x,int y)        //(x,y)的状态由本身的黑白 + 周围五个的翻转状态决定
{
    int temp = Map[x][y];
    for(int i = 0; i < 5; i ++)
    {
        int xi = x+dir[i][0];
        int yi = y+dir[i][1];
        if(xi < 1 || xi > n || yi < 1 || yi > m)
        {
            continue;
        }
        temp += cal[xi][yi];
    }
    return temp%2;
}
int dfs()
{
    for(int i = 2; i <= n; i ++)
    {
        for(int j = 1; j <= m; j ++)
        {
            if(fuc(i-1,j))      //如果上方为黑色,必须要翻转
            {
                cal[i][j] = 1;
            }
        }
    }
    for(int i = 1; i <= m; i ++)    //最后一行全白
    {
        if(fuc(n,i))
        {
            return -1;
        }
    }
    int res = 0;
    for(int i = 1; i <= n; i ++)
    {
        for(int j = 1; j <= m; j ++)
        {
            res += cal[i][j];
        }
    }
    return res;
}

int main()
{
    while(cin>>n>>m)
    {
        for(int i = 1; i <= n; i ++)
        {
            for(int j = 1; j <= m; j ++)
            {
                cin>>Map[i][j];
            }
        }
        int flag = 0;
        int ans = 0x3f3f3f3f;
        for(int i = 0; i < 1<<m; i ++)      //第一行 1<<m种状态,二进制从0开始,字典序从小到大
        {
            memset(cal,0,sizeof(cal));
            for(int j = 1; j <= m; j ++)    //利用二进制枚举第一行所有的情况
            {
                cal[1][m-j+1] = i>>(j-1) & 1;
            }
            int cont = dfs();
            if(cont >= 0 && cont < ans)         //翻转次数最少
            {
                flag = 1;
                ans = cont;
                memcpy(out,cal,sizeof(cal));
            }
        }
        if(!flag)
        {
            cout<<"IMPOSSIBLE"<<endl;
        }
        else
        {
            for(int i = 1; i <= n; i ++)
            {
                for(int j = 1; j <= m; j ++)
                {
                    if(j != 1)
                    {
                        cout<<" ";
                    }
                    cout<<out[i][j];
                }
                cout<<endl;
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值