D - Doing Homework (dp+位运算)

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework). 

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier. 

Output

For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one. 

Sample Input

2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3

Sample Output

2
Computer
Math
English
3
Computer
English
Math


        
  

Hint

In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the 
word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.

题目:每一门作业在规定的时间内做完就不扣分,如果超出规定时间超出一天扣一分。求出把所有作业做完扣分最少是多少,并且输出做作业的顺序。

n最大是15,所以可以把每个作业表示为0或1两种状态,然后dp 找出最少扣分的顺序。

代码:


//Full of love and hope for life

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <queue>
#define inf 0x3f3f3f3f
//https://paste.ubuntu.com/

using namespace std;

typedef long long ll;
const ll maxn=(1<<15)+10;

struct node{
   string s;
   int a,b;
}n[maxn];

int dp[maxn],pre[maxn],time[maxn];

void print(int x){
   if(x==0){
    return ;
   }
   print(x-(1<<pre[x]));
   cout << n[pre[x]].s << endl;
}

int main()
{
    int a,b;
    cin >> a;
    while(a--){
       memset(time,0,sizeof(time));
       memset(pre,0,sizeof(pre));
       memset(dp,0,sizeof(dp));
       cin >> b;
       for(int i=0;i<b;i++){
           cin >> n[i].s >> n[i].a >> n[i].b;
       }
       int k=1<<b;
       for(int i=1;i<k;i++){
        dp[i]=inf;
        for(int j=b-1;j>=0;j--){
            int t=1<<j;
            if(!(i&t)){
                continue;
            }
            int g=time[i-t]+n[j].b-n[j].a;
            g=g<0?0:g;
            /*
            if(g<0){
                g=0;
            }
            else{
                g=g;
            }
            */
            if(dp[i]>dp[i-t]+g){
                dp[i]=dp[i-t]+g;
                time[i]=time[i-t]+n[j].b;
                pre[i]=j;
             }
          }
       }
       cout << dp[k-1] << endl;
       print(k-1);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值