D - Sigma Function (唯一分解定理 + 思维)

Sigma function is an interesting function in Number Theory. It is denoted by the Greek letter Sigma (σ). This function actually denotes the sum of all divisors of a number. For example σ(24) = 1+2+3+4+6+8+12+24=60. Sigma of small numbers is easy to find but for large numbers it is very difficult to find in a straight forward way. But mathematicians have discovered a formula to find sigma. If the prime power decomposition of an integer is

Then we can write,

For some n the value of σ(n) is odd and for others it is even. Given a value n, you will have to find how many integers from 1 to n have even value of σ.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1012).

Output

For each case, print the case number and the result.

Sample Input

4

3

10

100

1000

Sample Output

Case 1: 1

Case 2: 5

Case 3: 83

Case 4: 947

题目就是这个样子的,首先我们看(p[i]^(e[i]+1) - 1)/(p[i] - 1) 这个等比数列和可以化简为

 p[i]^0 + p[i]^1 +.....+ p[i]^e[i];

首先我们可以知道如果p[i] = 2; 则其和一定为奇数(偶数+1);

我们知道除2以外,素数都是奇数,所以 (p[i]^0 + p[i]^1 +.....+ p[i]^e[i])要满足是奇数的话e[i]一定是偶数(两两组合还剩一个奇数);

所以满足sigm(i)是奇数的条件,则如果i是一个平方数,那么他的约数和一定是奇数,如果2*i是平方数,他的约数和也是奇数。。。减去即可!!!!!
(这谁能想到啊)

代码:


//Full of love and hope for life

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <queue>
#define inf 0x3f3f3f3f
//https://paste.ubuntu.com/

using namespace std;

typedef long long ll;
const ll maxn=1e6+100;

//这题谁能想得到啊

int main(){
    ll T,a,k=0;
    cin >> T;
    while(T--){
            k++;
        cin >> a;
        ll b=sqrt(a);//奇数的情况
        ll c=sqrt(a/2);//奇数的情况
        cout << "Case " << k << ": " << a-b-c << endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值