Rng HDU6574

Problem Description
Avin is studying how to synthesize data. Given an integer n, he constructs an interval using the following method: he first generates a integer r between 1 and n (both inclusive) uniform-randomly, and then generates another integer l between 1 and r (both inclusive) uniform-randomly. The interval [l, r] is then constructed. Avin has constructed two intervals using the method above. He asks you what the probability that two intervals intersect is. You should print p* q(−1)(MOD 1, 000, 000, 007), while pq denoting the probability.

Input
Just one line contains the number n (1 ≤ n ≤ 1, 000, 000).

Output
Print the answer.

Sample Input
1
2

Sample Output
1
750000006
运用递推求得最后的公式为ans=(n+1)/2*n;
需要大数取模,所以采用逆元

#include<iostream>
#include<cstdio>
#include<cmath>
#include<string>
using namespace std;
const int mod=1e9+7;
long long qp(long long a,long long b)
{
	long long ans=1;
	while(b)
	{
		if(b&1){
			ans=(ans%mod*a%mod)%mod;
		}
		a=(a%mod*a%mod)%mod;
		b>>=1;
	}
	return ans;
}
int main()
{
	long long n;
	while(cin>>n)
	{
		long long ans=((n+1)%mod*qp(2*n,mod-2)%mod)%mod;
		cout<<ans<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值