Drainage Ditches
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 70082 Accepted: 27205
Description
Every time it rains on Farmer John’s fields, a pond forms over Bessie’s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie’s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.
Sample Input
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10
Sample Output
50
-
题意:
这是一个纯正的,最基础的网络流中最大流问题。
给定 m个点,n条边,其中点1是源点,点m是汇点。接下来n行,给你3个数,边的起点,终点,容量,问你这幅图中最大流的值是多少。两点之间可能存在多条边,所以记两点之间的容量要用+=。
代码:#include<bits/stdc++.h>
using namespace std;
int G[300][300];
int Prev[300];
bool Visited[300];
int n,m; //n代表边数
unsigned Augment()
{
int v;
int i;
dequeq;
memset(Prev,0,sizeof(Prev));
memset(Visited,0,sizeof(Visited));
Prev[1]=0;
Visited[1]=1;
q.push_back(1);
bool bFindPath=false;
//使用bfs寻找一条从源到汇的可行路径
while (!q.empty())
{
v=q.front();
q.pop_front();
for (i=1;i<=m;i++)
{
if (G[v][i]>0&&Visited[i]0)
{
Prev[i]=v;
Visited[i]=1;
if (im)
{
bFindPath=true;
q.clear();
break;
}
else
q.push_back(i);
}
}
}
if (!bFindPath)
return 0;
int nMinFlow=999999999;
v=m;
//寻找从源到汇路径上容量最小的边 其容量就是此次增加的总流量
while (Prev[v])
{
nMinFlow=min(nMinFlow,G[Prev[v]][v]);
v=Prev[v];
}
v=m;
while (Prev[v])
{
G[Prev[v]][v]-=nMinFlow;
G[v][Prev[v]]+=nMinFlow;
v=Prev[v];
}
return nMinFlow;
}
int main()
{
while (cin >> n >> m ) {
//m是顶点数目,顶点编号从1开始
int i,j,k;
int s,e,c;
memset( G,0,sizeof(G)); for( i = 0;i < n;i ++ ) {
cin >> s >> e >> c;
G[s][e] += c; //两点之间可能有多条边
}
unsigned int MaxFlow = 0; unsigned int aug;
while( aug = Augment() ) MaxFlow += aug;
cout << MaxFlow << endl;
}
return 0;
}