KMP最小循环节及一些基础习题

kmp的next数组里存的是i之前的串的前缀和后缀匹配的最大长度,next[strlen(s)]就代表的是整个s串的前缀和后缀的最长匹配长度,用总长度减去这个值就是s串的最小循环节。
最小循环节的定义是一个串可以由某个串循环得到,不一定是整数次循环,
比如abca的最小循环节是abc
1:
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of “HDU CakeMan”, he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl’s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls’ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet’s cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a’ ~‘z’ characters. The length of the string Len: ( 3 <= Len <= 100000 ).
Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
Sample Input
3
aaa
abca
abcde
Sample Output
0
2
5
题意:求最少再补几个可以构成循环的序列,最小循环节的应用。用总长度-用最小循环节即为所求。
代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
const int MAXN=100010;
char str[MAXN];
int nnext[MAXN];
 
void getNext(char *p)
{
    int j,k;
    j=0;
    k=-1;
    int len=strlen(p);
    nnext[0]=-1;
    while(j<len)
    {
        if(k==-1||p[j]==p[k])
        {
            j++;
            k++;
            nnext[j]=k;
        }
        else k=nnext[k];
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",&str);
        getNext(str);  
        int len=strlen(str);
        //for(int i=0;i<=len;i++)
        //{
        	//printf("%d\n",nnext[i]);
		//}
        if(nnext[len]==0)
        {
            printf("%d\n",len);
            continue;
        }
        int t=len-nnext[len]; 
        if(len%t==0)printf("0\n");
        else
        {
            printf("%d\n",t-len%t);
        }
    }
    return 0;
}

2:
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4
题意:这题就是求可以由哪些循环节构成,所以要遍历长度,才能输出所有的结果。
代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e6+10;
int naxt[maxn];
char str[maxn];
int len;
void getnaxt()
{
	len=strlen(str);
	int i=0,j=-1;
	naxt[0]=-1;
	while(i<len)
	{
		if(j==-1||str[i]==str[j])
		{
			i++;
			j++;
			naxt[i]=j;
		}
		else
		{
		   j=naxt[j];
		}
	}
	
}
int main()
{
	int t;
	int ans=1;
	while(cin>>t&&t)
	{
		scanf("%s",str);
		printf("Test case #%d\n",ans++);
		getnaxt();
		for(int i=1;i<len;i++)
		{
			int k=i+1;
			if(k%(k-naxt[k])==0&&k/(k-naxt[k])!=1)
			{
				printf("%d %d\n",k,k/(k-naxt[k]));
			}
		}
		printf("\n");
	}
	return 0;
}
3:Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题意:就是字符串最多含有多少循环节。
代码:

 #include<stdio.h>
#include<string.h>
using namespace std;
const int maxn = 1e6+10;
int naxt[maxn];
char str[maxn];
int len;
void getnaxt()
{
	int i=0,j=-1;
	naxt[0]=-1;
	len=strlen(str);
	while(i<len)
	{
		if(j==-1||str[i]==str[j])
		{
			i++;
			j++;
			naxt[i]=j;
		}
		else
		{
			j=naxt[j];
		}
	}
}
int main()
{
	while(scanf("%s",str)&&str[0]!='.')
	{
		int len=strlen(str);
		getnaxt(); 
		{
			if(len%(len-naxt[len])==0&&len%(len-naxt[len])!=1)
			{
				printf("%d\n",len/(len-naxt[len]));
			}
			else
			{
				printf("1\n");
			}
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值