D - Hawk-and-Chicken(强连通缩点+bfs反向建图)

题目链接
Kids in kindergarten enjoy playing a game called Hawk-and-Chicken. But there always exists a big problem: every kid in this game want to play the role of Hawk.
So the teacher came up with an idea: Vote. Every child have some nice handkerchiefs, and if he/she think someone is suitable for the role of Hawk, he/she gives a handkerchief to this kid, which means this kid who is given the handkerchief win the support. Note the support can be transmitted. Kids who get the most supports win in the vote and able to play the role of Hawk.(A note:if A can win
support from B(A != B) A can win only one support from B in any case the number of the supports transmitted from B to A are many. And A can’t win the support from himself in any case.
If two or more kids own the same number of support from others, we treat all of them as winner.
Here’s a sample: 3 kids A, B and C, A gives a handkerchief to B, B gives a handkerchief to C, so C wins 2 supports and he is choosen to be the Hawk.
Input
There are several test cases. First is a integer T(T <= 50), means the number of test cases.
Each test case start with two integer n, m in a line (2 <= n <= 5000, 0 <m <= 30000). n means there are n children(numbered from 0 to n - 1). Each of the following m lines contains two integers A and B(A != B) denoting that the child numbered A give a handkerchief to B.
Output
For each test case, the output should first contain one line with “Case x:”, here x means the case number start from 1. Followed by one number which is the total supports the winner(s) get.
Then follow a line contain all the Hawks’ number. The numbers must be listed in increasing order and separated by single spaces.
Sample Input
2
4 3
3 2
2 0
2 1

3 3
1 0
2 1
0 2
Sample Output
Case 1: 2
0 1
Case 2: 2
0 1 2
解题思路:首先是强连通分量缩点,然后又一次构图,对于同一个强连通分量的点的支持度一是强连通分量内的其它点。还有其它的强连通分量对他所在强连通分量的支持,为了找到这个我们之前构图时反向建图,然后bfs。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<stack>
#include<queue>
using namespace std;
#define Max 5005
int head[Max],head2[Max],j,k,bcnt,dindex,dfn[Max],low[Max],belong[Max],sup[Max];
bool visit[Max],vis[Max];;
stack<int> s;
struct EDGE
{
    int s;
    int e;
    int next;
}edge[Max*6],edge2[Max*6];
void add(int s,int e)
{
    edge[k].s=s;
    edge[k].e=e;
    edge[k].next=head[s];
    head[s]=k++;
}
void add2(int s,int e)
{
    edge2[j].s=s;
    edge2[j].e=e;
    edge2[j].next=head2[s];
    head2[s]=j++;
}
void tarjan(int i)
{
    int ed;
    dfn[i]=low[i]=++dindex;
    visit[i]=true;
    s.push(i);
    for(int t=head[i];t!=-1;t=edge[t].next)
    {
        ed=edge[t].e;
        if(!dfn[ed])
        {
            tarjan(ed);
            if(low[i]>low[ed])
                low[i]=low[ed];
        }
        else if(visit[ed]&&low[i]>dfn[ed])
            low[i]=dfn[ed];
    }
    if(dfn[i]==low[i])
    {
        bcnt++;
        do
        {
            ed=s.top();
            s.pop();
            visit[ed]=false;
            belong[ed]=bcnt;
        }while(i!=ed);
    }
}
void solve(int n)
{
    int i;
    bcnt=dindex=0;
    memset(visit,false,sizeof(visit));
    memset(low,0,sizeof(low));
    memset(belong,0,sizeof(belong));
    memset(dfn,0,sizeof(dfn));
    while(!s.empty())
        s.pop();
    for(i=0;i<n;i++)
        if(!dfn[i])
            tarjan(i);
}
int bfs(int rt)
{
    int i,st,ed,sum=0;
    vis[rt]=true;
    queue<int> q;
    q.push(rt);
    while(!q.empty())
    {
        st=q.front();
        q.pop();
        for(i=head2[st];i!=-1;i=edge2[i].next)
        {
            ed=edge2[i].e;
            if(!vis[ed])
            {
                sum+=sup[ed]+1;
                q.push(ed);
                vis[ed]=true;
            }
        }
    }
    return sum;
}
int main()
{
    int i,t,m,n,a,b,ans[Max],sum[Max],flag,cnt,p[Max],ncase=1;
    scanf("%d",&t);
    while(t--)
    {
        flag=-1;
        j=k=cnt=0;
        memset(p,0,sizeof(p));
        memset(ans,0,sizeof(ans));
        memset(sum,0,sizeof(sum));
        memset(head,-1,sizeof(head));
        memset(head2,-1,sizeof(head2));
        memset(sup,0,sizeof(sup));
        scanf("%d%d",&n,&m);
        while(m--)
        {
            scanf("%d%d",&a,&b);
            add(a,b);
        }
        solve(n);
        for(i=0;i<k;i++)
        {
            int st=edge[i].s;
            int ed=edge[i].e;
            if(belong[st]!=belong[ed])
                add2(belong[ed],belong[st]);
        }
        for(i=0;i<n;i++)
            sup[belong[i]]++;
        for(i=1;i<=bcnt;i++)
            sup[i]--;
        for(i=1;i<=bcnt;i++)
        {
            memset(vis,false,sizeof(vis));
            sum[i]=bfs(i)+sup[i];
        }
        for(i=0;i<n;i++)
        {
            ans[i]=sum[belong[i]];
            flag=max(flag,ans[i]);
        }
        for(i=0;i<n;i++)
        {
            if(ans[i]==flag)
                p[cnt++]=i;
            //cout<<ans[i]<<endl;
        }
        printf("Case %d: %d\n",ncase++,flag);
        for(i=0;i<cnt;i++)
            printf("%d%c",p[i],i==cnt-1?'\n':' ');
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值