PAT 甲级 1009 Product of Polynomials (25分)——map容器的应用

题目描述:
This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ … N​K​​ a​N​K​​​​
where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

注意事项:

注意系数为0的项的处理——及时erase该项即可
map容器取出元素用容器名.erase(键)
eg. answer.erase(it->first)即可,变量的定义见代码

我的代码:

#include<iostream>
#include<cstdio>
#include<map>
using namespace std;

map<int,double>mp1,mp2,answer;

int main(){
	int m,n;
	cin>>m;
	for(int i=0;i<m;i++){
		int exponent;
		double coefficient;
		cin>>exponent>>coefficient;
		mp1[exponent]=coefficient;
	}
	cin>>n;
	for(int i=0;i<n;i++){
		int exponent;
		double coefficient;
		cin>>exponent>>coefficient;
		mp2[exponent]=coefficient;
	}
	for(map<int,double>::iterator it=mp1.begin();it!=mp1.end();it++){
		for(map<int,double>::iterator ite=mp2.begin();ite!=mp2.end();ite++){
			answer[it->first+ite->first]+=(it->second)*(ite->second);
			if(answer[it->first+ite->first]==0){
				answer.erase(it->first+ite->first);
			}
		}
	}

	cout<<answer.size();
	//指数从高到低进行输出
	for(map<int,double>::reverse_iterator it=answer.rbegin();it!=answer.rend();it++){
		if(it->second!=0){
			printf(" %d %.1f",it->first,it->second);
		}else{
			continue;
		}
	        
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值