PAT甲级1009 Product of Polynomials

1009 Product of Polynomials

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N 
1
​
  a 
N 
1
​
 
​
  N 
2
​
  a 
N 
2
​
 
​
  ... N 
K
​
  a 
N 
K
​
 
​
 

where K is the number of nonzero terms in the polynomial, N 
i
​
  and a 
N 
i
​
 
​
  (i=1,2,,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N 
K
​
 <<N 
2<N 
1
​
 ≤1000.

Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
结尾无空行
Sample Output:
3 3 3.6 2 6.0 1 1.6
结尾无空行

折磨点:
1、第一个用例不过的原因是输出的时候把指数(iter->second)为0的项也输出了,在输出位置添加条件即可(其实就是忘了。。。),至于有人说第一个用例不过是因为不能把条件写成!= 0,而是要写一个极小值进行比较,小于极小值的数约等于0,也有人说系数可能会出现负数导致不过(但是题目写了系数是整数啊),我是没出现这个情况。。。。

1002
这题可以对比1002看,这里总结一下多项式计算:
1、A + B:将相同系数的项的指数进行相加,系数为0的项也要输出,指数为0的项不输出

2、A * B:循环遍历B,对A中的所有项进行操作,A的系数加上B的系数,指数则在原来的基础上加上A的指数乘B的指数,系数为0的项也要输出,指数为0的项不输出

#include <iostream>
#include <map>
#include <climits>
#include <cmath>
using namespace std;

int main(){
    int n;
    cin >> n;
    map<int,double> mp;
    for(int i = 0;i < n;++i){
        int a;
        double b;
        cin >> a >> b;
        mp[a] = b;
    }
    int count = 0;
    cin >> n;
    map<int,double> Q;
    for(int i = 0;i < n;++i){
        int a;
        double b;
        cin >> a >> b;
        for(auto iter = mp.begin();iter != mp.end();++iter){
            if(Q.find(iter->first + a) != Q.end()){
                auto Qiter = Q.find(iter->first + a);
                Qiter->second += iter->second * b;
            }
            else{
                Q[iter->first + a] = iter->second * b;
            }
        }
    }
    for(auto i = Q.begin();i != Q.end();++i){
        if(i->first < 0){
            continue;
        }
        if(i->second != 0){
            count++;
        }
    }
    cout << count;
    for(auto i = Q.rbegin();i != Q.rend();++i){
        if(i->first >= 0&&i->second != 0){
            printf(" %d %.1lf",i->first,i->second);
        }
    }
    cout << endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值