PAT甲级 1009 Product of Polynomials (25分) C++

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1a​N1N2aN2​​ … NKaNK
​​
​​

where K is the number of nonzero terms in the polynomial, Ni and aNi
​​
​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K<⋯<N​2<N1≤1000.

Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

题目大意

给出2个多项式,求2个多项式相乘后的多项式积。

C++

#include<bits/stdc++.h>
using namespace std;
int main(){
	int k1, k2;
	cin>>k1;
	map<int, double> mp;//指数 -> 系数 
	map<int, double> mp2;
	while(k1--){
		int exp;
		double coe;
		cin >> exp >> coe;
		mp[exp] += coe;
	}
	cin>>k2;
	while(k2--){
		int exp;
		double coe;
		cin >> exp >> coe;
		mp2[exp] += coe;
	}
	map<int, double, greater<int>> mp3;
	//遍历2个多项式
	for(auto it : mp){
		for(auto it2 : mp2){
			int exp = it.first + it2.first;
			double coe = it.second * it2.second; 
			mp3[exp] += coe;
		}
	}
	//删除系数为零的项,测试点0
	for(auto it : mp3){
		if(it.second == 0){
			mp3.erase(it.first);
		}
	}
	cout<<mp3.size();
	for(auto it : mp3){
		printf(" %d %.1lf",it.first, it.second);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值