An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
Figure 1
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.
Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
入栈序列为pre,出栈序列为in,求post
#include <bits/stdc++.h>
#define pb push_back
#define mem(a,b) memset(a,b,sizeof a)
using namespace std;
typedef long long ll;
const int INF=0x3f3f3f3f;
int n,x,flag=1;
vector<int> pre,in;
void post(int root,int s,int e)
//s,e是中序的下标,root是先序的下标
{
if(s>e) return ;
int i=s;
while(i<=e &&pre[root]!=in[i]) i++;
post(root+1,s,i-1);
post(root+i+1-s,i+1,e);//i是下标,i-s是长度
if(flag==1)
{
cout<<pre[root];
flag=0;
}
else cout<<" "<<pre[root];
//形参为 *in,*pre,len时,in,pre需为数组,不可为vector
// if(!len) return ;
// int i=0;
// while(in[i]!=pre[0]) i++;
// post(in,pre+1,i);
// post(in+i+1,pre+i+1,len-i-1);
// if(len==n) cout<<pre[0];
// else cout<<" "<<pre[0];
}
int main()
{
// freopen("D:\\LYJ.txt","r",stdin);
string s;
stack<int> sk;
cin>>n;
for(int i=0;i<n*2;i++)
{
cin>>s;
if(s=="Push")
{
cin>>x;
sk.push(x);
pre.pb(x);
}
else if(s=="Pop")
{
in.pb(sk.top());
sk.pop();
}
}
post(0,0,n-1);
return 0;
}