1086 Tree Traversals Again (25分)

题目

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N ( ≤ 30 ) N(\le30) N(30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N N N). Then 2 N 2N 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

题目大意

给出一系列栈的操作,根据出栈入栈过程以及中序遍历结果建立一个树,可以证明这棵树是唯一的,现在要输出这棵树的后序遍历结果。

思路

我们知道建立一棵树单单只靠中序遍历是不行的,所以必须结合栈操作,我们模拟建树过程,会发现这样一个规律;

  1. 前一步操作是Push时,那么这一步Push就是插入左子树;
  2. 前一步操作是Pop时,那么这一步Push就是插入右子树;
    节点值直接用下标表示,这样在找父节点的时候直接下标访问即可,具体代码如下;

代码

#include <iostream>
#include <cstdio>
#include <stack>
#include <vector>
using namespace std;

struct node{
    int left;
    int right;
}node[31];

vector<int> ans;

void postorder(int root){
    if(root == -1)
        return;
    postorder(node[root].left);
    postorder(node[root].right);
    ans.push_back(root);
}

int main(){
    int n, p, root;
    stack<int> sta;
    char op[5];
    scanf("%d", &n);
    for(int i=1; i<=n; i++)
        node[i].left = -1, node[i].right = -1;
    int d = 0, o = 0;
    for(int i=0; i<2*n; i++){
        scanf("%s", op);
        if(op[1] == 'u'){
            scanf("%d", &p);
            sta.push(p);
            if(d == 0)
                root = p;
            else{
                if(o == 0)
                    node[d].left = p;
                else
                    node[d].right = p;
            }
            d = p, o = 0;
        }
        else{
            d = sta.top();
            o = 1;
            sta.pop();
        }
    }
    postorder(root);
    for(int i=0; i<ans.size(); i++){
        if(i)
            printf(" ");
        printf("%d", ans[i]);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值