Lowcode-engine安装-启动(linux环境)

1.简介阿里低代码引擎-Lowcode-engine

低代码引擎是一款为低代码平台开发者提供的,具备强大定制扩展能力的低代码设计器研发框架(阿里的低代码引擎是为创建低代码平台而生!!!)。
阿里低代码平台官网:添加链接描述
阿里低代码平台参考文档:添加链接描述
阿里低代码平台协议规范:添加链接描述

2.Linux运行lowcode-engine

为什么在linux运行lowcode-engine,查阅官网文档可知,lowcode-engine直接在windows环境运行会报错,要么安装WSL(Window安装linux环境),要么选择直接在自己虚拟机运行即可!!!
在这里插入图片描述

(1)运行环境要求

Gitee中Lowcode-engine:官方开源地址(打不开Github的可以选择)
在这里插入图片描述

  1. linux安装nodejs14(必须14),请参考博客:Nodejs14安装
  2. cnpm安装参考:安装cnpm
  3. VSCode连接远程linux请参考:VSCode连接远程

(2)使用xftp将Gitee中下载的lowcode-engine-main .zip上传并解压(zip解压请参考:zip解压

解压之后,并修改文件名
1.Xshell进入lowcode-engine-main目录(已经npm install成功,所以会有node_modules目录)
进入目录,也可以选择VScode
2.命令行运行一下命令

cnpm install
cnpm run setup
cnpm start

这是本地运行,其中运行cnpm run setup会报sh: ./scripts/setup.sh: 权限不够,运行以下命令即可解决

chmod 777 ./scripts/setup.sh

若需先其他问题可以参考百度。
3.启动成功(注意如果开防火墙的话,请记得打开5555端口,参考:linux防火墙开放5555端口
启动成功!!!
VScode打开可以编辑,运行(相当于 Xshell)

在这里插入图片描述

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:大白 设计师:CSDN官方博客 返回首页
评论 1

打赏作者

我是一块小鸭子

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值