PAT 1001 A+B Format (20分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10^​6
≤a,b≤10^​6​​ . The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

简单的数字、字符串转化问题

1、运用了C语言中sprintf(s,"%d",sum)函数,将sum整数型以字符数组型写入到s中。

2、打印‘,’,i为遍历下标,字符串长度len,则len - 1 - i为从个位开始到第i位的位数;i < len - 1,防止’,'在数前数尾打印;s[i] != '-'避免在负号后打印。

注意:’,’ 是从个位开始计数,每三位打印一个’,’


我的代码

#include<cstdio>
#include<cstring>
int main()
{
    int a,b;
    scanf("%d%d",&a,&b);
    int sum = a + b;
    char s[10];
    sprintf(s,"%d",sum);
    int len = strlen(s);   
    for (int i = 0 ;i < len ;i++)
    {
        printf("%c",s[i]);
        if ((len - 1 - i) % 3 == 0 && i < len - 1 && s[i] != '-')
            printf(",");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

情书、

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值