PAT 1003 Emergency (25分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C​2
​​ .

Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C1 and C​2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

最短路径问题
只需要简单的Dijkstra算法


我的代码:

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 510;
const int INF = 1000000;
int n,m,bg,ed;
//n为城市个数,m为路径条数,bg为起点,ed为终点
int mp[maxn][maxn],team[maxn],d[maxn],t[maxn] = {0},same[maxn] = {0};
//mp[maxn][maxn]为记录各点之间的距离;team[maxn]为各点的人数;d[maxn]为源点到各点的最短距离;
//t[maxn]为源点到各点的最大救援人数;same[maxn]为源点到各点最短路径的条数
bool flag[maxn] = {false};
void Dijkstra(int v)
{
    fill(d,d + maxn,INF);
    same[v] = 1;
    d[v] = 0;
    t[v] = team[v];//初始化各表源点数据
    for (int i = 0 ;i < n ;i++)
    {
        int s = -1,min = INF;//s为源点到下一个最短路径的点的下标
        for (int j = 0 ;j < n ;j++)
        {
            if (flag[j] == false && min > d[j])
            {
                s = j;
                min = d[j]; 
            }
        }      
        if (s == -1) break;//表示每个点已经遍历完成
        flag[s] = true;//已遍历该点
        for (int j = 0 ;j < n ;j++)
        {
        	//在路径存在,且未遍历过的点中更新数据
            if (mp[s][j] != INF && d[j] > mp[s][j] + d[s] && flag[j] == false)
            {
                d[j] = mp[s][j] + d[s];
                same[j] = same[s];
                t[j] = team[j] + t[s];
            }
            else if (mp[s][j] != INF && d[j] == mp[s][j] + d[s] && flag[j] == false)
            {
                if (t[j] < t[s] + team[j])
                    t[j] = t[s] + team[j];
                same[j] += same[s];
            }
        }
    }
}
int main()
{
    scanf("%d%d%d%d",&n,&m,&bg,&ed);
    fill(mp[0],mp[0] + maxn * maxn,INF);//初始化各路径距离
    for (int i = 0 ;i < n ;i++)
        scanf("%d",&team[i]);     
    for (int i = 0 ;i < m ;i++)
    {
        int c1,c2,l;
        scanf("%d%d%d",&c1,&c2,&l);
        mp[c1][c2] = mp[c2][c1] = l;
    }
    Dijkstra(bg);
    printf("%d %d\n",same[ed],t[ed]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

情书、

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值