As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.
Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2
.
Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.
Sample Input:
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output:
2 4
最短路径问题
只需要简单的Dijkstra算法
我的代码:
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 510;
const int INF = 1000000;
int n,m,bg,ed;
//n为城市个数,m为路径条数,bg为起点,ed为终点
int mp[maxn][maxn],team[maxn],d[maxn],t[maxn] = {0},same[maxn] = {0};
//mp[maxn][maxn]为记录各点之间的距离;team[maxn]为各点的人数;d[maxn]为源点到各点的最短距离;
//t[maxn]为源点到各点的最大救援人数;same[maxn]为源点到各点最短路径的条数
bool flag[maxn] = {false};
void Dijkstra(int v)
{
fill(d,d + maxn,INF);
same[v] = 1;
d[v] = 0;
t[v] = team[v];//初始化各表源点数据
for (int i = 0 ;i < n ;i++)
{
int s = -1,min = INF;//s为源点到下一个最短路径的点的下标
for (int j = 0 ;j < n ;j++)
{
if (flag[j] == false && min > d[j])
{
s = j;
min = d[j];
}
}
if (s == -1) break;//表示每个点已经遍历完成
flag[s] = true;//已遍历该点
for (int j = 0 ;j < n ;j++)
{
//在路径存在,且未遍历过的点中更新数据
if (mp[s][j] != INF && d[j] > mp[s][j] + d[s] && flag[j] == false)
{
d[j] = mp[s][j] + d[s];
same[j] = same[s];
t[j] = team[j] + t[s];
}
else if (mp[s][j] != INF && d[j] == mp[s][j] + d[s] && flag[j] == false)
{
if (t[j] < t[s] + team[j])
t[j] = t[s] + team[j];
same[j] += same[s];
}
}
}
}
int main()
{
scanf("%d%d%d%d",&n,&m,&bg,&ed);
fill(mp[0],mp[0] + maxn * maxn,INF);//初始化各路径距离
for (int i = 0 ;i < n ;i++)
scanf("%d",&team[i]);
for (int i = 0 ;i < m ;i++)
{
int c1,c2,l;
scanf("%d%d%d",&c1,&c2,&l);
mp[c1][c2] = mp[c2][c1] = l;
}
Dijkstra(bg);
printf("%d %d\n",same[ed],t[ed]);
return 0;
}