PAT 1009 Product of Polynomials (25分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2… N​K aN​K where K is the number of nonzero terms in the polynomial, Ni and a​N​i(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N
​K<⋯<N2<N1≤1000.

Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

坑点:
1、多项式相乘结果,指数最大值为2000(测试点3,4)

2、系数为零的项不输出

我的代码:

#include<cstdio>
#include<map>
using namespace std;
const int maxn = 2010;
int main()
{
    int k,ep,cnt = 0;
    double co,result[maxn] = {0};
    map<int,double> p;
    scanf("%d",&k);
    for (int j = 0 ;j < k ;j++)
    {
        scanf("%d%lf",&ep,&co);
        p[ep] = co;
    }
    scanf("%d",&k);
    for (int j = 0 ;j < k ;j++)
    {
        scanf("%d%lf",&ep,&co);
        for (auto it = p.begin() ;it != p.end() ;it++)
            result[ep + it->first] += co * it->second;
    }
    for (int i = 0 ;i < maxn ;i++)
    {
        if (result[i] != 0)
            cnt++;
    }
    printf("%d",cnt);
    for (int i = maxn - 1 ;i >= 0 ;i--)
    {
        if (result[i] != 0)
            printf(" %d %.1f",i,result[i]);        
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

情书、

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值