Milking Time
Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0…N-1) so that she produces as much milk as possible.
Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.
Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.
Input
- Line 1: Three space-separated integers: N, M, and R
- Lines 2…M+1: Line i+1 describes FJ’s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi
Output - Line 1: The maximum number of gallons of milk that Bessie can product in the N hours
Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output
43
解题思路:因为时间的段数M<=1000,所以用dp[i]表示以第i段时间作为最后一段时间一共能产多少牛奶
AC代码:
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<queue>
#include<string>
#include<sstream>
#include<cmath>
#include<set>
#define maxn 1000000000
using namespace std;
typedef long long ll;
int n,m,r;
struct F
{
int a,b,c;
bool operator < (const F&t)const
{
return a<t.a; //根据每一段时间的开头排序
}
};
F intervals[1005];
int main()
{
cin>>n>>m>>r;
for(int i=0;i<m;i++)
{
scanf("%d%d%d",&intervals[i].a,&intervals[i].b,&intervals[i].c);
intervals[i].b+=r; //把每一次产奶所需休息的时间加上去
}
sort(intervals,intervals+m);
int dp[1005];
int sum=dp[0]=intervals[0].c;
for(int i=1;i<m;i++)
{
dp[i]=intervals[i].c;
for(int j=i-1;j>=0;j--)
{
if(intervals[i].a>=intervals[j].b)
dp[i]=max(dp[i],dp[j]+intervals[i].c); //算出以第i段时间作为结尾的最大产奶量
}
sum=max(sum,dp[i]);
}
cout<<sum;
return 0;
}