J - Milking Time POJ - 3616(dp动态规划)

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0…N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

  • Line 1: Three space-separated integers: N, M, and R
  • Lines 2…M+1: Line i+1 describes FJ’s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

  • Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output
43
题意:这个人要在n个小时内生产最多量的牛奶,两个时间段不能重叠。典型的动态规划,在处理到每一个时间段的时候,都要回过头去遍历一下前面的那些时间段。然后来更新。
代码如下:

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
struct node{//定义一个结构体来储存开始时间,结束时间,以及产生的价值
	int stime;
	int etime;
	int effect;
};
struct node p[1010];
int dp[1010];//代表从开始到这个时间段可以生产的牛奶最大量
bool cmp(const node a,node b)//按着开始时间来排序
{
	return a.stime<b.stime;
}
int main()
{
	int n,m,k;
	cin>>n>>m>>k;
	for(int i=0;i<m;i++)
	{
		cin>>p[i].stime>>p[i].etime>>p[i].effect;
	}
	sort(p,p+m,cmp);//排序
	for(int i=0;i<m;i++)
	{
		dp[i]=p[i].effect;//一开始定义为这样,下面的循环开始更新
		for(int j=0;j<i;j++)
		{
			if(p[j].etime+k>p[i].stime) continue;
			dp[i]=max(dp[i],dp[j]+p[i].effect);//更新
		}
	}
	  int maxx=0;
		for(int i=0;i<m;i++)
		{
			if(dp[i]>maxx)
			maxx=dp[i];
		}
		cout<<maxx<<endl;
	return 0;
}

努力加油a啊,(o)/~

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值