c++ 数字转字符串

利用sstream中的stringstream转换(可以是浮点数)

#include <stdio.h>
#include <string>
#include <iostream>
#include <sstream>
using namespace std;

int main(){
    int a=1001;
    string s;
    stringstream ss;
    ss<<a;
    ss>>s;
    cout<<s<<endl;
    return 0;
}
#include <stdio.h>
#include <string>
#include <iostream>
#include <sstream>
using namespace std;

int main(){
    float a=100.123;
    string s;
    stringstream ss;
    ss<<a;
    ss>>s;
    cout<<s<<endl;
    return 0;
}

实例:PAT 1001 A+B Format
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10^6 ≤a,b≤ 10^6​​.The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

AC代码:

#include <stdio.h>
#include <string>
#include <sstream>
#include <iostream>
using namespace std;

int main(){
    int a,b,c;
    string s;
    stringstream ss;
    scanf("%d%d",&a,&b);
    c=a+b;
    ss<<c;
    ss>>s;
    int count=0;
    for(int i=s.length()-1;i>=0;i--){
        count++;
        if(count==3){
            if(i==0 || (i==1&&s[0]=='-'))
                break;
            count=0;
            s.insert(i,",");
        }
    }
    cout<<s<<endl;
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值