螺旋矩阵

常规螺旋矩阵:输入行数m和列数n,从1到m*n生成螺旋矩阵。

#include <stdio.h>

int main(){
    int m,n;
    scanf("%d%d",&m,&n);
    int now=1;    //当前位置
    int u=1,d=m,l=1,r=n;    //上、下、左、右四个边界
    int i=1,j=1;
    int matrix[m+1][n+1]={0};
    while(now<=m*n){
    	//最上层从左向右
        while(now<=m*n&&j<r){
            matrix[i][j]=now;
            now++;
            j++;
        }
        //最右侧从上向下
        while(now<=m*n&&i<d){
            matrix[i][j]=now;
            now++;
            i++;
        }
        //最下层从右向左
        while(now<=m*n&&j>l){
            matrix[i][j]=now;
            now++;
            j--;
        }
        //最左侧从下向上
        while(now<=m*n&&i>u){
            matrix[i][j]=now;
            now++;
            i--;
        }
        u++,d--,l++,r--;
        i++,j++;
        if(now==m*n){
            matrix[i][j]=now++;
        }
    }
    for(int i=1;i<=m;i++){
        for(int j=1;j<=n;j++){
            printf("%2d ",matrix[i][j]);
        }
        printf("\n");
    }
    return 0;
}

运行结果:
在这里插入图片描述
在这里插入图片描述
实例:PAT 1105 Spiral Matrix

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10^​4. The numbers in a line are separated by spaces.

Output Specification:
For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

AC代码:

#include <stdio.h>
#include <algorithm>
using namespace std;

bool cmp(int a,int b){
    return a>b;
}

int main(){
    int N,m,n;
    int a[10010];
    scanf("%d",&N);
    for(int i=1;i<=N;i++)
        scanf("%d",&a[i]);
    if(N==1){
        printf("%d\n",a[1]);
        return 0;
    }
    sort(a+1,a+1+N,cmp);
    int min=10010;
    for(int i=1;i<=N;i++){
        for(int j=1;j<=i;j++){
            if(i*j==N){
                if(i-j<min){
                    min=i-j;
                    m=i;
                    n=j;
                }
            }
        }
    }
    int now=1;
    int u=1,d=m,l=1,r=n;
    int i=1,j=1;
    int matrix[m+1][n+1]={0};
    while(now<=m*n){
        while(now<=m*n&&j<r){
            matrix[i][j]=a[now++];
            j++;
        }
        while(now<=m*n&&i<d){
            matrix[i][j]=a[now++];
            i++;
        }
        while(now<=m*n&&j>l){
            matrix[i][j]=a[now++];
            j--;
        }
        while(now<=m*n&&i>u){
            matrix[i][j]=a[now++];
            i--;
        }
        u++,d--,l++,r--;
        i++,j++;
        if(now==m*n){
            matrix[i][j]=a[now++];
        }
    }
    for(int i=1;i<=m;i++){
        for(int j=1;j<=n;j++){
            if(j==n)
                printf("%d",matrix[i][j]);
            else
                printf("%d ",matrix[i][j]);
        }
        printf("\n");
    }
    return 0;
}

思路来源:https://www.cnblogs.com/zzlback/p/9688971.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值