栈合集(PAT甲级)

PAT 1051 Pop Sequence

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

思路:题目要求按照1-n的顺序入栈(栈有容量限制),判断一个给定序列是否可能为出栈顺序。将序列存在数组v中,设置一个cnt=1。从1-n开始入栈,如果超过了栈的容量就break,接着当栈顶元素等于v[cnt]时让栈顶元素出栈并且cnt++。循环结束后如果cnt等于n+1,输出YES,否则输出NO。

AC代码:

#include <stdio.h>
#include <vector>
#include <stack>
using namespace std;

int main(){
    int m,n,k;
    scanf("%d%d%d",&m,&n,&k);
    for(int i=0;i<k;i++){
        stack<int> s;
        vector<int> v(n+1);
        int cnt=1;
        for(int j=1;j<=n;j++){
            scanf("%d",&v[j]);
        }
        for(int j=1;j<=n;j++){
            s.push(j);
            if(s.size()>m)
                break;
            while(!s.empty()&&s.top()==v[cnt]){
                s.pop();
                cnt++;
            }
        }
        if(cnt==n+1)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值