Window Pains POJ - 2585(拓扑排序在覆盖问题中的运用)

题目

Boudreaux likes to multitask, especially when it comes to using his computer. Never satisfied with just running one application at a time, he usually runs nine applications, each in its own window. Due to limited screen real estate, he overlaps these windows and brings whatever window he currently needs to work with to the foreground. If his screen were a 4 x 4 grid of squares, each of Boudreaux’s windows would be represented by the following 2 x 2 windows:
1 1 . .
1 1 . .
. . . .
. . . .

. 2 2 .
. 2 2 .
. . . .
. . . .

. . 3 3
. . 3 3
. . . .
. . . .
. . . .
4 4 . .
4 4 . .
. . . .

. . . .
. 5 5 .
. 5 5 .
. . . .

. . . .
. . 6 6
. . 6 6
. . . .
. . . .
. . . .
7 7 . .
7 7 . .

. . . .
. . . .
. 8 8 .
. 8 8 .

. . . .
. . . .
. . 9 9
. . 9 9
When Boudreaux brings a window to the foreground, all of its squares come to the top, overlapping any squares it shares with other windows. For example, if window 1 and then window 2 were brought to the foreground, the resulting representation would be:
1 2 2 ?
1 2 2 ?
? ? ? ?
? ? ? ?
If window 4 were then brought to the foreground:
1 2 2 ?
4 4 2 ?
4 4 ? ?
? ? ? ?
. . . and so on . . .
Unfortunately, Boudreaux’s computer is very unreliable and crashes often. He could easily tell if a crash occurred by looking at the windows and seeing a graphical representation that should not occur if windows were being brought to the foreground correctly. And this is where you come in . . .
Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 3 components:
Start line - A single line:
START

Screen Shot - Four lines that represent the current graphical representation of the windows on Boudreaux’s screen. Each position in this 4 x 4 matrix will represent the current piece of window showing in each square. To make input easier, the list of numbers on each line will be delimited by a single space.
End line - A single line:
END

After the last data set, there will be a single line:
ENDOFINPUT

Note that each piece of visible window will appear only in screen areas where the window could appear when brought to the front. For instance, a 1 can only appear in the top left quadrant.
Output
For each data set, there will be exactly one line of output. If there exists a sequence of bringing windows to the foreground that would result in the graphical representation of the windows on Boudreaux’s screen, the output will be a single line with the statement:

THESE WINDOWS ARE CLEAN

Otherwise, the output will be a single line with the statement:
THESE WINDOWS ARE BROKEN

Sample Input

START
1 2 3 3
4 5 6 6
7 8 9 9
7 8 9 9
END
START
1 1 3 3
4 1 3 3
7 7 9 9
7 7 9 9
END
ENDOFINPUT

Sample Output

THESE WINDOWS ARE CLEAN
THESE WINDOWS ARE BROKEN

解释

题目所给4*4屏幕,共九个任务框,注意位置已固定。所以只要对每个任务框,记录所在框范围有哪些任务框覆盖了该任务框,将其存下,变成一个拓扑序列来思考。注意边只存一次,因为存在任务框覆盖另一任务框超过一次的情况。
如果出现死机说明序列图中存在自环,所以借助拓扑排序来判断是否存在自环。

#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
#include <iostream>
using namespace std;
int G[4][4], vis[10], exsit[10][10];
vector<int> p[10];
int inde[10];
void create(int u, int v, int k){

	int a, b;
	for (int i = 0; i <= 1; i++){
		for (int j = 0; j <= 1; j++){
			a = i+u;
			b = j + v;		
			if(!exsit[G[a][b]][k] && G[a][b] != k){
					exsit[G[a][b]][k] = 1;
					p[G[a][b]].push_back(k);
					inde[k]++;
			}
		
		}
	}

}
int const n = 4;
int tp(){
    queue<int> Q;
    int i, j;
    for(i = 1; i <= 9; i++)
        if(!inde[i])
            Q.push(i);
    int t, cont = 0;
    while(!Q.empty()){
        t = Q.front();
        cont++;
        Q.pop();
        for(i = 0; i <p[t].size(); i++){
            inde[p[t][i]]--;
            if(!inde[p[t][i]])
                Q.push(p[t][i]);
        }

    }
    if(cont < 9)
            return 0;
    return 1;
}
int main(){
	string s;
	while (cin >>s){
		if(s == "ENDOFINPUT") break;
		memset(vis, 0, sizeof(vis));
		memset(exsit, 0, sizeof(exsit));
		memset(inde, 0, sizeof(inde));
		for(int i = 1; i <= 9; i++)
			p[i].clear();
		for (int i = 0; i < n; i++){
			for (int j = 0; j < n; j++){
				cin >> G[i][j];
			}
		}
	
		cin >> s;
		for (int k = 1; k <= 9; k++){
			create((k-1)/3, (k-1)%3, k);
		} 
		if(tp())
			printf("THESE WINDOWS ARE CLEAN\n");
		
		else
			printf("THESE WINDOWS ARE BROKEN\n");
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值