POJ 2585 Window Pains (拓扑排序)

Window Pains

Boudreaux likes to multitask, especially when it comes to using his computer. Never satisfied with just running one application at a time, he usually runs nine applications, each in its own window. Due to limited screen real estate, he overlaps these windows and brings whatever window he currently needs to work with to the foreground. If his screen were a 4 x 4 grid of squares, each of Boudreaux’s windows would be represented by the following 2 x 2 windows:
1 1 . .
1 1 . .
. . . .
. . . .
. 2 2 .
. 2 2 .
. . . .
. . . .
. . 3 3
. . 3 3
. . . .
. . . .
. . . .
4 4 . .
4 4 . .
. . . .
. . . .
. 5 5 .
. 5 5 .
. . . .
. . . .
. . 6 6
. . 6 6
. . . .
. . . .
. . . .
7 7 . .
7 7 . .
. . . .
. . . .
. 8 8 .
. 8 8 .
. . . .
. . . .
. . 9 9
. . 9 9
When Boudreaux brings a window to the foreground, all of its squares come to the top, overlapping any squares it shares with other windows. For example, if window 1 and then window 2 were brought to the foreground, the resulting representation would be:
1 2 2 ?
1 2 2 ?
? ? ? ?
? ? ? ? If window 4 were then brought to the foreground:
1 2 2 ?
4 4 2 ?
4 4 ? ?
? ? ? ?. . . and so on . . .
Unfortunately, Boudreaux’s computer is very unreliable and crashes often. He could easily tell if a crash occurred by looking at the windows and seeing a graphical representation that should not occur if windows were being brought to the foreground correctly. And this is where you come in . . .
Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 3 components:
Start line - A single line:
START

Screen Shot - Four lines that represent the current graphical representation of the windows on Boudreaux’s screen. Each position in this 4 x 4 matrix will represent the current piece of window showing in each square. To make input easier, the list of numbers on each line will be delimited by a single space.
End line - A single line:
END

After the last data set, there will be a single line:
ENDOFINPUT

Note that each piece of visible window will appear only in screen areas where the window could appear when brought to the front. For instance, a 1 can only appear in the top left quadrant.
Output
For each data set, there will be exactly one line of output. If there exists a sequence of bringing windows to the foreground that would result in the graphical representation of the windows on Boudreaux’s screen, the output will be a single line with the statement:

THESE WINDOWS ARE CLEAN

Otherwise, the output will be a single line with the statement:
THESE WINDOWS ARE BROKEN

Sample Input
START
1 2 3 3
4 5 6 6
7 8 9 9
7 8 9 9
END
START
1 1 3 3
4 1 3 3
7 7 9 9
7 7 9 9
END
ENDOFINPUT

Sample Output
THESE WINDOWS ARE CLEAN
THESE WINDOWS ARE BROKEN

将44的方格存放九种22的方格的方案,以22方格的左上角的坐标表示整个方格,那么一共有九个位置,然后依次遍历,当22的方格出现别的数字,即此方格被覆盖,就形成了先后的关系,因此可以存图,然后接着遍历,将入度为0的点及边去掉,如果存在剩余的点入度都不为0,那么即为BROKEN,否则为CLEAN。
ac代码:

#include<iostream>
#include<algorithm>
#include<string.h>
#include<cstring>
using namespace std;
	char s[100];
	int ma[10][10];
	int dis[10][10];
	int in[12];
int mm[10][2]={-1,-1,0,0,0,1,0,2,1,0,1,1,1,2,2,0,2,1,2,2};//可能出现的九个2*2的方格左上格的坐标
int d[4][2]={0,0,0,1,1,0,1,1};//一个2*2的方格从左上角开始遍历
bool top(){
	int x;
	for(int i=1;i<=9;i++){
		int flag=0;
		for(int j=1;j<=9;j++){
			if(in[j]==0){//入度为0,即此时该2*2方格上方没有其他方格覆盖
			//	cout<<j<<endl;
				flag=1;
				x=j;
				break;
			}
		}
		//cout<<flag<<endl;
		if(flag==0) return 0;//即成环,互相覆盖,不合法,break
		in[x]=-1;
		for(int j=1;j<=9;j++){
		//	cout<<"dis[x][j]:"<<dis[x][j]<<endl;
			if(dis[x][j])
				in[j]--;//去掉该入度为0的点的边
		}
		
	}
	
	return 1;
}
int main(){

	while(cin>>s&&strcmp(s,"ENDOFINPUT")!=0){
		memset(dis,0,sizeof(dis));
		memset(in,0,sizeof(in));
		for(int i=0;i<4;i++){
			for(int j=0;j<4;j++){
				cin>>ma[i][j];
			}
		}
		cin>>s;
		for(int i=1;i<=9;i++){
			for(int j=0;j<4;j++){
				int x=mm[i][0]+d[j][0];
				int y=mm[i][1]+d[j][1];
				int ss=ma[x][y];
				if(ss!=i&&!dis[i][ss]){//遍历,该点被其他方格覆盖,即形成先后的关系
					dis[i][ss]=1;
					in[ss]++;
				}
			}
		}
		//for(int i=1;i<=9;i++) cout<<"in[i]:"<<in[i]<<endl;
		if(top()) cout<<"THESE WINDOWS ARE CLEAN"<<endl;
		else cout<<"THESE WINDOWS ARE BROKEN"<<endl;
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值