Aladdin and the Flying Carpet

Aladdin and the Flying Carpet

It’s said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin’s uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input
Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output
For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2

思路:
这个题的题意是:给你一个n,然后求两个数相乘为n,这两个数不相同,并且有最小值限制,求有多少种这样的可能。
这个题你可以先求出n的所有的因子,然后对于每一个因子都有与之对应的另一个因子,使他们相乘为n,所以让n的因子数除以2,即为满足要求点的对数,有一种情况是n开方后为整数,那样所有的因子个数是一个奇数,但是,那一种情况又不符合要求,所以可以直接除以2,然后取整。
那一个最小值可以用循环去除,有不满足的就把结果减一。
具体看代码:

Code:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=1e6+5;
int pp[N];//标记用的 
ll p[N];//保存质数用的 
ll n,q;
ll k;
void init(){//把质数保存下来 
	k=0;
	memset(pp,0,sizeof pp);
	pp[0]=pp[1]=1;
	for(ll i=2;i<N;i++){
		if(!pp[i]){
			p[k++]=i;
			for(ll j=i*i;j<N;j+=i)
				pp[j]=1;
		}
	}
}
ll ppp(){//求质因数个数的模板 
	ll res=1;
	for(ll i=0;p[i]*p[i]<=n&&i<k;i++){
		ll cot=0;
		if(n%p[i]==0){
			while(n%p[i]==0){
				cot++;
				n/=p[i];
			}
			res*=(cot+1);
		}
	}
	if(n>1)res=res*2;
	return res;
}
int main()
{
	int t;
	int kk=1;
	cin>>t;
	init();//记得不要忘了。。。 
	while(t--){
		cin>>n>>q;
		ll nn=n;
		if(q*q>=n){//特判一下,不满足的话直接输出0 
			printf("Case %d: 0\n",kk++);
			continue;
		}
		else{
			ll ans=ppp();//求出有多少个因子 
			ans/=2;//因为是长方形,有一半是重复的所以要除以2,就算有n^(1/2),这个值,它也是不满足的(因为需要是长方形),所以除以2取整是对的。 
			for(ll i=1;i<q;i++){
				if(nn%i==0)ans--;//去掉最小边小于题目给的最小长度。 
			}
			printf("Case %d: %lld\n",kk++,ans);//输出结果 
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值