Nearest Common Ancestors
A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:
In the figure, each node is labeled with an integer from {1, 2,…,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.
For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.
Write a program that finds the nearest common ancestor of two distinct nodes in a tree.
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,…, N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.
Output
Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.
Sample Input
2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5
Sample Output
4
3
LCA求最近公共祖先
Nearest Common Ancestors
#include <iostream>
#include <vector>
#include <cstring>
using namespace std;
const int LCA_N=10001;
int n,m,q;
vector<int> tree[LCA_N];
vector<int> query[LCA_N];
int anc[LCA_N];
int indegree[LCA_N];
int r[LCA_N];
int vis[LCA_N];
int f[LCA_N];
//初始化f[i]=i,vis[]为标记是否搜索过
void init(int n)
{
memset(vis,0,sizeof vis);
for(int i=1;i<=n;i++)
{
f[i]=i;
r[i]=1;
indegree[i]=0;
anc[i]=0;
tree[i].clear();
query[i].clear();
}
}
int find_set(int x)
{//寻找点x的祖先结点
if(f[x]!=x)
{
f[x]=find_set(f[x]);
}
return f[x];
}
//寻找x,y的祖先结点,然后比较
int union_set(int x,int y)
{
int fx=find_set(x);
int fy=find_set(y);
if(fx==fy)
{
return 0;
}
else if(r[fx]<=r[fy])
{
f[fx]=fy;
r[fy]+=r[fx];
}
else
{
f[fy]=fx;
r[fx]+=r[fy];
}
return 1;
}//合并函数,如果属于同一分支则返回0,成功合并返回1
//遍历一遍
void LCA(int u)
{
anc[u]=u;
for(int i=0;i<tree[u].size();i++)
{
int child=tree[u][i];
if(!vis[child])
{
LCA(child);
union_set(u,child);
anc[find_set(u)]=u;
vis[child]=1;//搜索过进行标记
}
}
for(int i=0;i<query[u].size();i++)
{
int v=query[u][i];
if(vis[v])
{
cout << anc[find_set(v)] << endl;
return;
}
}
}
int main()
{
int t;
cin >> t;
while(t--)
{
int n;
cin >> n;
init(n);
int p,q;
for(int i=1;i<n;i++)
{
cin >> p >> q ;
tree[p].push_back(q);//p为q的父节点
indegree[q]++;
}
cin >> p >> q;
query[p].push_back(q);
query[q].push_back(p);
for(int i=1;i<=n;i++)
{
if(indegree[i]==0)
{
LCA(i);
break;
}
}
}
return 0;
}