UVA-537--Artificial Intelligence?(C语言)

题目描述:

 		Artificial Intelligence?

Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!

So they don’t state a problem like U=10V, I=5A, P=?" but rather likeYou have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There’s an electrical current of I=5A through the bulb. Which power is generated in the bulb?".

However, half of the pupils just don’t pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: ``Which formulae do I know? Ah yes, P=UI. Therefore P=10V5A=500W. Finished."

OK, this doesn’t always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)

Today we will check if a computer can pass a high school physics test. We will concentrate on the P-U-I type problems first. That means, problems in which two of power, voltage and current are given and the third is wanted.

Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.

Input
The first line of the input file will contain the number of test cases.
Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the form I=xA, U=xV or P=xW, where x is a real number.

Directly before the unit (A, V or W) one of the prefixes m (milli), k (kilo) and M (Mega) may also occur. To summarize it: Data fields adhere to the following grammar:

DataField ::= Concept ‘=’ RealNumber [Prefix] Unit
Concept ::= ‘P’ | ‘U’ | ‘I’
Prefix ::= ‘m’ | ‘k’ | ‘M’
Unit ::= ‘W’ | ‘V’ | ‘A’
Additional assertions:

The equal sign (`=’) will never occur in an other context than within a data field.
There is no whitespace (tabs,blanks) inside a data field.
Either P and U, P and I, or U and I will be given.

Output
For each test case, print three lines:
a line saying ``Problem #k" where k is the number of the test case
a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output
a blank line

Sample Input
3
If the voltage is U=200V and the current is I=4.5A, which power is generated?
A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please.
bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?

Sample Output
Problem #1
P=900.00W
Problem #2
I=0.45A
Problem #3
u=1250000.00v

解题思路:

这个题主要是从字符串中找到等号,把“=”前面的内容记录到一个字符中,再把数字存到另一个字符,判断U、I、P中确少那一个,利用公式进行计算。注意单位应该化到统一的国际单位再计算。

程序代码:

#include<stdio.h>
#include<string.h>
int main()
{
	double t,h,a,b,P,I,U;
	char s[1010];
	int n,k,i,j,cas,f;
	scanf("%d",&n);	
	getchar();
	for(cas=1;cas<=n;cas++)
	{
		printf("Problem #%d\n",cas);
		P=0.0;I=0.0;U=0.0;k=0;
		fgets(s,sizeof(s),stdin);
		for(i=0;s[i]!='\0';i++)
		{
			a=0.0;
			if(s[i+1]=='='&&(s[i]=='U'||s[i]=='P'||s[i]=='I'))
			{
				t=1.0;f=0;
				for(j=i+2;s[j]!='V'&&s[j]!='A'&&s[j]!='W';j++)
				{
					if(s[j]=='m')
						a*=0.001;
					else if(s[j]=='k')
						a*=1000.0;
					else if(s[j]=='M')
						a*=1000000.0;
					else if(s[j]=='.')
						f=1;
					else
					{
						if(f==1)
							a+=(t*=0.1)*(s[j]-'0');
						else
							a=a*10+s[j]-'0';
					}	
				}
				if(s[i]=='P')
					P=a;
				else if(s[i]=='U')
					U=a;
				else
					I=a;
				if(k==0)
				{
					k=1;
					i=j;
				}
				else 
					break;
			}
		}
		if(U==0.0)
			printf("U=%.2lfV\n\n",P/I);
		else if(I==0.0)
			printf("I=%.2lfA\n\n",P/U);
		else 
			printf("P=%.2lfW\n\n",U*I);		
	}
	return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

我菜就爱学

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值