Wormholes—POJ3259

Problem Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself ?

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2… M+1 of each farm: Three space-separated numbers ( S, E, T) that describe,
respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields
might be connected by more than one path.
Lines M+2… M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe,
respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1… F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Problem solving report:

Description:路径的遍历是双向的,虫洞的传送时间是单向的,通过路径和虫洞能否使他看到最初的自己。
Problem solving: 这个题是在存在负权边的情况下是否存在负权回路,输入时一共存入2*m个边表示双向,存入虫洞时只存入一次表示单向,利用Ford算法最后重新遍历一遍点的坐标,如果还存在最短路发生变化就会出现负权回路。

Accepted Code:

#include<stdio.h>
int main()
{
	int N;
	scanf("%d",&N); 
	while(N--){
		int dis[30000],i,k,n,m,u[30000],v[30000],w[30000],check,flag,t;
		int inf=99999999;
		int a,b,c;
		scanf("%d%d%d",&n,&m,&t);
		for(i=1;i<=2*m;){
			scanf("%d%d%d",&a,&b,&c);
			u[i]=a;
			v[i]=b;
			w[i++]=c;
			u[i]=b;
			v[i]=a;
			w[i++]=c;
		}	
		for(i=2*m+1;i<=2*m+t;i++){
			scanf("%d%d%d",&a,&b,&c);
			u[i]=a;
			v[i]=b;
			w[i]=-c;
			
		}
		for(i=1;i<=n;i++)
			dis[i]=inf;
		dis[1]=0;
		for(k=1;k<n;k++){
			check=0;
			for(i=1;i<=2*m+t;i++){
				if(dis[v[i]]>dis[u[i]]+w[i]){
					dis[v[i]]=dis[u[i]]+w[i];
					check=1;
				}		
			}
			if(check=0)
				break;
		}
		flag=0;
		for(i=1;i<=2*m+t;i++)
			if(dis[v[i]]>dis[u[i]]+w[i])
				flag=1;
		if(flag==1)
			printf("YES\n");
		else
			printf("NO\n");	
	}

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

我菜就爱学

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值