HDU2680-Choose the best route(经典最短路问题dijkstra算法)

###Choose the best route
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
Sample Input
5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1
Sample Output
1
-1

题意:kiki 要到朋友家去,已知站点数,通车线路以及朋友家附近的车站。kiki可以从家附近的几个站点出发,求最少的时间花费。

分析:这是一个有向图,是一个典型的最短路问题。但是,从kiki角度出发,起点有多个;从kiki朋友家出发,逆着走,只有一个起点。根据dijkstra算法的特点,我们有两种思路:
思路一:我们造出一个起点 0 他与 kiki家附近的车站点的距离为 0,这就解决了多起点问题。
思路二:倒着走,从kiki朋友家出发逆着走,再去几个车站中的最小值。

方法一:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int inf =0x3f3f3f3f;
const int MAX = 1005;  
int n, m, s;  
int map[MAX][MAX], dis[MAX], vis[MAX];  

void dijkstra()
{
    memset(vis,0,sizeof(vis));
    int i,j,pos,minn;
    for(i=1; i<=n; i++)
        dis[i]=map[0][i];
    vis[0]=1;
    for(i=0; i<=n; i++)
    {
        minn=inf;
        for(j=1; j<=n; j++)
            if(dis[j]<minn && !vis[j])
           {
              minn=dis[j];
              pos=j;
           }
        if(minn==inf) break;
        vis[pos]=1;
        for(j=1; j<=n; j++)
        {
            if(dis[j]>dis[pos]+map[pos][j] && !vis[j])
                dis[j]=dis[pos]+map[pos][j];
        }
    }
}

int main()
{
    while(~scanf("%d%d%d",&n,&m,&s))
    {
       memset(map,inf,sizeof(map));
       for(int i=0; i<=n; i++)
          map[i][i]=0;
       int p,q,t;
       for(int i=0; i<m; i++)
       {
           scanf("%d%d%d",&p,&q,&t);
           map[p][q]=min(map[p][q],t);
       }

       int w,tmp;
       scanf("%d",&w);
       for(int i=1; i<=w; i++)
        {
            scanf("%d",&tmp);
            map[0][tmp]=0;
        }
       dijkstra();
       if(dis[s]==inf)
          printf("-1\n");
       else
          printf("%d\n",dis[s]);

    }

}

方法二:

#include <cstdio>  
#include <cstring>  
#include <algorithm>  
#define inf 0x3f3f3f3f  
using namespace std;  
  
const int MAX = 1005;  
int n, m, s;  
int map[MAX][MAX], dis[MAX], vis[MAX];  
  
void dijkstra(int s)  
{  
     memset(vis, 0, sizeof(vis)); 
    for(int i=1; i<=n; i++)
        dis[i] = map[s][i];  //初始化
    vis[s] = 1; dis[s] = 0;  
    int minn,pos;
    for(int i=1; i<n; i++)  
    {  
        minn=inf; 
        for(int j = 1; j <= n; j++)  
            if(!vis[j] && dis[j] < minn)  
                minn = dis[pos = j];  
        if(minn == inf)  break;  
        vis[pos] = 1;  
        for(int j=1; j<=n; j++)  
            if(!vis[j] && dis[pos] + map[pos][j] < dis[j])  
                dis[j] = dis[pos] + map[pos][j];  
    }  
}  
  
int main()  
{  
    while(scanf("%d %d %d", &n, &m, &s) != EOF)  
    {   
        memset(map, inf, sizeof(map));  
        while(m--)  
        {  
            int x, y, w;  
            scanf("%d %d %d", &x, &y, &w);  
            if(w < map[y][x]) map[y][x] = w;     //注意是有向的,反方向   
        }  
        dijkstra(s);  
        int a, b, ans = inf;  
        scanf("%d", &b);  
        for(int i=1; i<=b; i++)  
        {  
            scanf("%d", &a);  
            ans = min(ans, dis[a]);  //寻找最小的站点
        }  
        if(ans != inf)printf("%d\n", ans);  
        else printf("-1\n");  
    }  
    return 0;  
}  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值